<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Rolex 24 Hours of Daytona  begins Speedweeks 2020 | Up North Motorsports</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://upnorthmotorsports.bangordailynews.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/html5.js"></script>
	<![endif]-->
		<script>
		dataLayer = [{"event":"dataLayer-loaded","companyName":"Bangor Daily News","contentType":"home","author":"Tom Hale","contentPublishedDate":"2020-01-26","contentPublishedTime":"2020-01-26 23:48:31-05:00","lastUpdatedTime":"2020-01-26 23:48:31-05:00","primaryCategory":"Home","allCategories":"Home","visitorIP":"107.123.25.40, 52.72.19.74, 34.226.14.170,10.0.12.99","wordCount":1642}];
	</script>
<script>
	var gtmSetupOptions = {"tagManagerId":"GTM-W3QLSF","autoRun":true};
</script><link rel='dns-prefetch' href='//upnorthmotorsports.bangordailynews.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//bdn-data.s3.amazonaws.com' />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Feed" href="http://upnorthmotorsports.bangordailynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Comments Feed" href="http://upnorthmotorsports.bangordailynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Rolex 24 Hours of Daytona  begins Speedweeks 2020 Comments Feed" href="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/upnorthmotorsports.bangordailynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300,400,700,300italic,400italic,700italic|Roboto+Slab:400italic,700italic,400,700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-style-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/style.css?ver=2016-10-24' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/GTM-DataLayer/assets/js/gtm.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='http://upnorthmotorsports.bangordailynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://upnorthmotorsports.bangordailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://upnorthmotorsports.bangordailynews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Maine&#8217;s Griffeth turf on full display at Daytona as Speedweeks gets underway' href='http://upnorthmotorsports.bangordailynews.com/2020/01/19/home/maines-griffeth-turf-on-full-display-at-daytona-as-speedweeks-gets-underway/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" />
<link rel='shortlink' href='https://wp.me/p4zeJP-1fy' />
<link rel="alternate" type="application/json+oembed" href="http://upnorthmotorsports.bangordailynews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fupnorthmotorsports.bangordailynews.com%2F2020%2F01%2F26%2Fhome%2Frolex-24-hours-of-daytona-begins-speedweeks-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://upnorthmotorsports.bangordailynews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fupnorthmotorsports.bangordailynews.com%2F2020%2F01%2F26%2Fhome%2Frolex-24-hours-of-daytona-begins-speedweeks-2020%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>        
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51c20b68617564b1" data-minify="no" ></script>
	<script type="text/javascript">	    
        var addthis_config = {
            data_ga_tracker:'UA-5329647-48',
            data_track_addressbar:false
	    }; 
	    var addthis_share = {
            url: 'https://wp.me/p4zeJP-1fy',
            title: 'Rolex 24 Hours of Daytona  begins Speedweeks 2020',
            templates: {
                twitter: '{{title}}: {{url}} (via @bangordailynews)',
            }
	    };
        
        addthis.layers({
            'theme' : 'transparent',
                'share' : {
                  'position' : 'left',
                  'numPreferredServices' : 4,
                  'services' : "facebook,twitter,pinterest,email,more",
                'postShareFollowMsg' : "Follow Up North Motorsports:",
                  'offset' : {'top' : '320px'}
                }, 
            'follow' : {
              'services' : [
            {'service': 'facebook', 'id': 'bangordailynews'},
            {'service': 'twitter', 'id': 'bangordailynews'},
            {'service': 'rss', 'id': 'http://upnorthmotorsports.bangordailynews.com/feed/'}
              ],
              'offset' : {'top': '30px'}
            },  
            'whatsnext' : {} 
	  });
	  

	</script>
	<!-- AddThis Smart Layers END -->
    
    <!-- Please call pinit.js only once per page -->
    <!--I'm putting this here so it's only called once-->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>
    
    
    <script type="text/javascript">
        var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
        (function () {
	        var gads = document.createElement("script");
	        gads.async = true;
	        gads.type = "text/javascript";
	        var useSSL = "https:" == document.location.protocol;
	        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
	        var node = document.getElementsByTagName("script")[0];
	        node.parentNode.insertBefore(gads, node);
        })();
        </script>
                <script type="text/javascript">
        googletag.cmd.push(function() {
            var pid_value = "rolex-24-hours-of-daytona-begins-speedweeks-2020";
	    googletag.defineSlot('/21682974628/bangordailynews', [[300,250], [300,600]], "bdnads-blogs-top-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "top");
	    googletag.defineSlot('/21682974628/bangordailynews', [300,250], "bdnads-blogs-bottom-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "bottom");
        googletag.defineSlot('/21682974628/bangordailynews', [[970,250], [970,90]], "bdnads-blogs-top-leaderboard")
            .addService(googletag.pubads())
            .setTargeting("pos", "top");

                            googletag.defineSlot('/21682974628/bangordailynews', [300,50], "bdnads-blogs-mobile-300x50")
	            .addService(googletag.pubads())
                .setTargeting("pos", "mobile");
	        googletag.defineSlot('/21682974628/bangordailynews', [[300,250]], "bdnads-inline-300x250")
		        .addService(googletag.pubads())
		        .setTargeting("pos", "inline");

        
							googletag.pubads().setTargeting( 'author', 'blog' );
			            googletag.pubads().setTargeting("pid", pid_value);
                        googletag.pubads().setTargeting("kw", ['Up North Motorsports', 'sports', 'blog']);
            googletag.pubads().enableSingleRequest();           
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
	});
	</script>
    	<style type="text/css" id="bdnblog2013-header-css">
			.site-header {
			background: url(http://upnorthmotorsports.bangordailynews.com/files/2014/04/cropped-IMGP0002.jpg) no-repeat scroll top;
			background-size: 1600px auto;
		}
			.site-title,
		.site-description {
			color: #ffffff;
		}
		</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Rolex 24 Hours of Daytona  begins Speedweeks 2020" />
<meta property="og:url" content="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" />
<meta property="og:description" content="Milestone Episode 300 includes Rolex 24 Hours of Daytona and Tame the Track Snowmobile Racing Tour results from Rangeley Snodeo 2020." />
<meta property="article:published_time" content="2020-01-27T04:48:31+00:00" />
<meta property="article:modified_time" content="2020-01-27T04:48:31+00:00" />
<meta property="og:site_name" content="Up North Motorsports" />
<meta property="og:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-Daytona-Fireworks-2018-Lou-Masciarelli-photo.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="720" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Rolex 24 Hours of Daytona  begins Speedweeks 2020" />
<meta name="twitter:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-Daytona-Fireworks-2018-Lou-Masciarelli-photo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bdnmaineblogs" />
<style type='text/css'>.site-title, .site-description {
text-shadow: 2px 2px #333;
}</style></head>

<body class="post-template-default single single-post postid-4808 single-format-standard single-author sidebar">


		<script type="text/javascript">
	(function() {
	  var ARTICLE_URL = window.location.href;
	  var CONTENT_ID = 'everything';
	  document.write(
	    '<scr'+'ipt '+
	    'src="//survey.g.doubleclick.net/survey?site=_co4sl7ki43vcs'+
	    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	    '&amp;random='+(new Date).getTime()+
	    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	})();
	</script>
    
	 <div id="fb-root"></div>
	 <script>(function(d, s, id) {
			 var js, fjs = d.getElementsByTagName(s)[0];
			 if (d.getElementById(id)) return;
			 js = d.createElement(s); js.id = id;
			 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=748756371893770";
			 fjs.parentNode.insertBefore(js, fjs);
		 }(document, 'script', 'facebook-jssdk'));</script>
    
	<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
            <div class="home-link">
				<a href="http://upnorthmotorsports.bangordailynews.com/" title="Up North Motorsports" rel="home">
					<h1 class="site-title">Up North Motorsports</h1>
                    <h2 class="site-description">People and events in motorsports</h2>
				</a>
                <a class="bdn-link" href="http://bangordailynews.com/maine-blogs/?utm_source=Up+North+Motorsports&utm_medium=footer">
	                <!--                    <img src="-->
	                <!--/images/BDN_Square.jpg" width="32" alt="BDN Maine" title="BDN Maine"/>-->
	                <!--                    Blog-->
	                <img src="http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/images/bdn_blogs_logo.jpg" alt="BDN Maine"
	                     title="BDN Maine"/>
                </a>
            </div>
			<div id="navbar" class="navbar">
				<nav id="site-navigation" class="navigation main-navigation" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
					<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
					<div class="menu-menu-1-container"><ul id="menu-menu-1" class="nav-menu"><li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14"><a href="http://upnorthmotorsports.bangordailynews.com/">Home</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="http://upnorthmotorsports.bangordailynews.com/about-tom/">About Tom</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="http://upnorthmotorsports.bangordailynews.com/contact/">Contact</a></li>
<li id="menu-item-1907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1907"><a href="http://upnorthmotorsports.bangordailynews.com/snowmobile-snox-results-more-from-daytona-and-indianapolis/">Snowmobile SnoX Results, More From Daytona and Indianapolis</a></li>
</ul></div>					<form role="search" method="get" id="searchform" class="search-form" action="http://upnorthmotorsports.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form>				</nav><!-- #site-navigation -->
			</div><!-- #navbar -->
		</header><!-- #masthead -->

                <div class="adSpot widget">
            <div id="bdnads-blogs-oop-interstitial">
                <script type="text/javascript">
                    googletag.cmd.push(function () {
                        googletag.display("bdnads-blogs-oop-interstitial");
                    });
                </script>
            </div>
        </div>
                            <div class="adSpot widget">
                                    <div id="bdnads-blogs-top-leaderboard">
                        <script type="text/javascript">
                            googletag.cmd.push(function () {
                                googletag.display("bdnads-blogs-top-leaderboard");
                            });
                        </script>
                    </div>
                            </div>
            <div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

						
				<article id="post-4808" class="post-4808 post type-post status-publish format-standard has-post-thumbnail hentry category-home">
	<header class="entry-header">
		
            <h1 class="entry-title">Rolex 24 Hours of Daytona  begins Speedweeks 2020</h1>

		
		<div class="entry-meta">
			<span class="date"><a href="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" title="Permalink to Rolex 24 Hours of Daytona  begins Speedweeks 2020" rel="bookmark"><time class="entry-date" datetime="2020-01-26T23:48:31+00:00">January 26, 2020</time></a></span><span class="categories-links"><a href="http://upnorthmotorsports.bangordailynews.com/category/home/" rel="category tag">Home</a></span>					    <div class="author-byline">
			By <a href="http://upnorthmotorsports.bangordailynews.com/author/thale10/" title="Posts by Tom Hale" rel="author">Tom Hale</a>		    </div><!-- /.author-byline -->
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	<div class="entry-content entry">

        
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Rolex 24 Hours of Daytona  begins Speedweeks 2020."
               data-url="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-Daytona-Fireworks-2018-Lou-Masciarelli-photo-250x250.jpg&description=Rolex 24 Hours of Daytona  begins Speedweeks 2020" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


		<div class="p402_premium">
			<p>Episode <strong>300</strong> (Wow)</p>
<p>January 26, 2020</p>
<p><span style="color: #ff0000"><em><strong>Rolex 24 Hours of Daytona</strong></em></span></p>
<div id="attachment_4813" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-hrs-2020-starting-field-IMSA-photo.jpg"><img class="size-large wp-image-4813" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-hrs-2020-starting-field-IMSA-photo-600x359.jpg" alt="" width="600" height="359" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-hrs-2020-starting-field-IMSA-photo-600x359.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-hrs-2020-starting-field-IMSA-photo-450x269.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-hrs-2020-starting-field-IMSA-photo-768x459.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-hrs-2020-starting-field-IMSA-photo.jpg 1000w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The 38 car starting field for the 58th running of the Rolex 24 Hours of Daytona endurance race. From left to right GTD class with 19 entries, GTLM with 7 cars, LMP2 with 5 cars and DPi with 8 entries. With only six cautions the 2018 record of 808 laps was smashed as the winning #10 Cadillac DPi ran 833 laps. (IMSA photo)</p></div>
<p>As reported in last week&#8217;s episode, I was unable to attend the Rolex 24 Hours of Daytona in person. I did however, have Lou Masciarelli of Massachusetts agree to send me a few photos and share some thoughts about the race. The local TV station, WAGM had just added NBC to their lineup. NBC carried the final 1 1/2 hours of the race.</p>
<p>I also monitored the race via IMSA Radio throughout the evening. Endurance racing has some unique characteristics that I enjoy. The cars are built for the long race and actually are built like lightweight tanks. You also are able to get close to the action and watch passing since four classes are on the track at one time.</p>
<div id="attachment_4815" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-at-night-with-winner-IMSA-photo.jpg"><img class="size-large wp-image-4815" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-at-night-with-winner-IMSA-photo-600x338.jpg" alt="" width="600" height="338" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-at-night-with-winner-IMSA-photo-600x338.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-at-night-with-winner-IMSA-photo-450x253.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-at-night-with-winner-IMSA-photo-768x432.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Race winning DPi Cadillac of Wayne Taylor Racing going through the Bus Stop on the backstretch. The team set a new record with 833 laps, had 41 pit stops, and finished about a minute ahead of the #77 Mazda DPi. With this win, Cadillac has won the last four Rolex 24 Hours of Daytona races. Three of the four belong to Wayne Taylor Racing. (IMSA photo)</p></div>
<div id="attachment_4816" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-Mazda-finished-second-Lou-Mascerelli-photo.jpg"><img class="size-large wp-image-4816" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-Mazda-finished-second-Lou-Mascerelli-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-Mazda-finished-second-Lou-Mascerelli-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-Mazda-finished-second-Lou-Mascerelli-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-Mazda-finished-second-Lou-Mascerelli-photo-768x512.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Mazda DPi #77 driven by Oliver Jarvis, Tristan Nunez, and Olivier Pla. Their second place finish was the first time a Mazda has finished the Rolex 24 Hours of Daytona since 2012. (Lou Mascarelli photo)</p></div>
<div id="attachment_4817" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-LMP2-winner-Dragonspeed-IMSA-photo.jpg"><img class="size-large wp-image-4817" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-LMP2-winner-Dragonspeed-IMSA-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-LMP2-winner-Dragonspeed-IMSA-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-LMP2-winner-Dragonspeed-IMSA-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-LMP2-winner-Dragonspeed-IMSA-photo-768x512.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Winner of the LMP2 class was the Oreca chassis/Gibson powered Dragon Speed Racing #81 driven by Ben Hanley, Henrik Hedman, Harrison Newey, and Colin Braun. You may recall Braun formerly drove for CORE Autosports owned by Jon Bennett who has close Maine ties. This was the second straight class win for Dragon Speed. (IMSA photo)</p></div>
<div id="attachment_4818" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-4-Corvette-spend-8-hours-in-garage-fixing-oil-leak-Chevy-Racing-photo.jpg"><img class="size-large wp-image-4818" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-4-Corvette-spend-8-hours-in-garage-fixing-oil-leak-Chevy-Racing-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-4-Corvette-spend-8-hours-in-garage-fixing-oil-leak-Chevy-Racing-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-4-Corvette-spend-8-hours-in-garage-fixing-oil-leak-Chevy-Racing-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-4-Corvette-spend-8-hours-in-garage-fixing-oil-leak-Chevy-Racing-photo-768x512.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-2020-4-Corvette-spend-8-hours-in-garage-fixing-oil-leak-Chevy-Racing-photo.jpg 1200w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The new Corvette mid-engine C8.R did well. The sister car to the #4 pictured here placed fourth in the GTLM class. This Corvette was an example of perseverance. After an oil leak was detected at hour nine. The team took the car to the garage. Such was the leak that the team had to take the engine out of the car to repair the problem. Despite a nine-hour repair the Corvette went back out onto the track and finished the race with 461 laps and 18 pit stops. (Chevy Racing photo)</p></div>
<div id="attachment_4819" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-2020-Lexus-with-Kyle-Busch-Lexus-photo.jpg"><img class="size-large wp-image-4819" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-2020-Lexus-with-Kyle-Busch-Lexus-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-2020-Lexus-with-Kyle-Busch-Lexus-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-2020-Lexus-with-Kyle-Busch-Lexus-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-2020-Lexus-with-Kyle-Busch-Lexus-photo-768x512.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-24-2020-Lexus-with-Kyle-Busch-Lexus-photo.jpg 1280w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Lexus RC F GT3 #14 driven by Kyle Busch, Jack Hawksworth, Parker Chase, and Michael de Quesada finished ninth in class and drew more than its fair share of attention with two-time NASCAR champion Busch at the wheel. The team had brake issues early on and dropped back eight laps behind the leader. (Lexus Racing photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Comments about and from the NASCAR driver</strong></em></span></p>
<p>Fellow Lexus driver Jack Hawksworth, “Kyle’s got a lot of ideas. Kyle’s super switched on and he is like a sponge. He studies the setup, he studies the driving, and every aspect of it. He’s been good, he’s been helpful in many elements of the car setup. Again, anyone like him, he’s obsessed with it, so he’s thinking about it all of the time and constantly trying to improve it. So, he’s been good to work with.&#8221;</p>
<p>Kyle Busch had this to say about his first Rolex 24 Hours of Daytona race, “It was good, it was fine. Racing at night, people were talking about how difficult it was and I’ve been to some short tracks that don’t have very good lights, so there were plenty of lights here to see around. Obviously sometimes when you’re following a guy, or having a guy follow you, their lights are in your mirror the entire lap around the race track. That’s a bit difficult, but it’s not too bad getting the experience of running at night and having my first 24 hour was pretty cool. We’ll see what happens next.”</p>
<p><span style="color: #ff0000"><em><strong>Thanks to Lou Masciarelli</strong></em></span></p>
<p>I met Lou at the 2018 Rolex 24 Hours of Daytona while strolling on the frontstretch  grass before the race. He has been to many sports car races including multiple trips to the Daytona race. I have used some Masciarelli material in the past and relied on him a bunch this year in my absence from the track. I want to publicly thank him for his support!</p>
<div id="attachment_4820" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Lou-Mascerelli-Daytona-5-K-after-his-photo.jpg"><img class="size-large wp-image-4820" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Lou-Mascerelli-Daytona-5-K-after-his-photo-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Lou-Mascerelli-Daytona-5-K-after-his-photo-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Lou-Mascerelli-Daytona-5-K-after-his-photo-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Lou-Mascerelli-Daytona-5-K-after-his-photo-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">For the first time, Lou Masciarelli ran the Rolex 5K early on race day Saturday morning. He told me he would let me know if that was a good idea later that night. (Lou Masciarelli photo)</p></div>
<p><span style="color: #ff0000"><em><strong>The finishing touches on Jason Griffeth&#8217;s frontstretch turfgrass artistry</strong></em></span></p>
<div id="attachment_4821" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Jason-Griffeth-2020-Daytona-Logo-DIS-photo.jpg"><img class="size-large wp-image-4821" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Jason-Griffeth-2020-Daytona-Logo-DIS-photo-600x309.jpg" alt="" width="600" height="309" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Jason-Griffeth-2020-Daytona-Logo-DIS-photo-600x309.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Jason-Griffeth-2020-Daytona-Logo-DIS-photo-450x232.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Jason-Griffeth-2020-Daytona-Logo-DIS-photo-768x395.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The 2020 Speedweeks frontstretch turf artistry with the Daytona logo. (DIS photo)</p></div>
<p><span style="color: #ff0000"><em><b style="color: #ff0000">Tame the Track Snowmobile </b><span style="color: #ff0000"><b>Racing</b></span><b style="color: #ff0000"> Tour at </b><span style="color: #ff0000"><b>Rangeley</b></span><b style="color: #ff0000"> Snodeo</b></em></span></p>
<p>NAPA Auto Parts 2020 Tame the Track Snowmobile Tour results  from the Rangeley Lakes Snowmobile Club Snodeo &#8212; &#8220;Adrenaline Rush Reunion&#8221; January 25, 2020</p>
<p>Dysart&#8217;s Truck Stop, Cyr &amp; Sons Repair, KLIM KIDS 120cc STOCK &#8212;<br />
1) Malcolm Witham Jr: Carmel, ME, Polaris<br />
2) Trenton Hanscom: Benton, ME, Polaris<br />
3) Breenan Comeau: Nashua, NH, Polaris</p>
<p>Recreational Motorsports &amp; Machias Savings Bank KIDS 120cc IMPROVED/LO 206 &#8212;<br />
1) Evan Folsom: Barre, VT, Polaris<br />
2) Breenan Comeau: Nashua, NH, Polaris<br />
3) Tucker Chase: Stratton, ME, Arctic Cat</p>
<div id="attachment_4810" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-Rangely-may-be-kids-class-EAH-photo.jpg"><img class="size-large wp-image-4810" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-Rangely-may-be-kids-class-EAH-photo-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-Rangely-may-be-kids-class-EAH-photo-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-Rangely-may-be-kids-class-EAH-photo-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-Rangely-may-be-kids-class-EAH-photo-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Tame the Track 120 Modified class at Rangeley Snodeo 2020. (Elizabeth Agnew Hartford photo)</p></div>
<p>Witham&#8217;s Paving, Daigle Oil Company KIDS 120cc MODIFIED<br />
1) Riley Hartford: Wolfeboro, NH, Polaris<br />
2) Evan Witham: Levant, Maine, NH, Polaris<br />
3) Mason Silva: Hudson, ME, Polaris</p>
<p>Corinth Village Creamery &amp; Willette&#8217;s Automotive KIDS 200 STOCK<br />
1) Cayleigh Rose: Turner, ME, Arctic Cat<br />
2) Jayden Huff: Hampden, ME, Arctic Cat<br />
3) Tucker Chase: Stratton, ME, Arctic Cat</p>
<p>Casella Waste Systems/ Pine Tree Waste WOMEN&#8217;S INVITATIONAL &#8212;<br />
1)  Haley Brownell: Ossipee, NH, Yamaha<br />
2) Haley Frohlich: Auburn, ME, Polaris<br />
3) Alley Ripley: Center Ossipee, NH, Yamaha</p>
<div id="attachment_4809" style="width: 460px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-juniors-EAH-at-Rangely-2020-2.jpg"><img class="size-large wp-image-4809" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-juniors-EAH-at-Rangely-2020-2-450x600.jpg" alt="" width="450" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-juniors-EAH-at-Rangely-2020-2-450x600.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-juniors-EAH-at-Rangely-2020-2-338x450.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Tame-the-Track-juniors-EAH-at-Rangely-2020-2.jpg 720w" sizes="(max-width: 450px) 100vw, 450px" /></a><p class="wp-caption-text">Tame the Track Juniors at Rangeley Snodeo 2020. Riley Hartford on#789 on the inside with Austin Witham #5 on the outside, closest in the photo. (Elizabeth Agnew Hartford photo)</p></div>
<p>TNT Road Company &amp; Last Chance Motorsports JUNIORS INVITATIONAL &#8212;<br />
1) Riley Hartford: Wolfeboro, NH, Yamaha<br />
2)  Austin Witham: Levant, ME, Yamaha<br />
3) Hailey Hartford: Wolfeboro, NH, Yamaha</p>
<p>Workstore and Houlton Powersports &amp; RV TEENS INVITATIONAL &#8212;<br />
1) Christian Hanscom: Benton, ME, Yamaha<br />
2) Henry Moneypenny: West Ossipee, NH, Yamaha<br />
3) Landon Collins: Wolfeboro, NH, Yamaha</p>
<p>Blanchard&#8217;s Towing &amp; VIP Tires SINGLE CYLINDER STOCK<br />
1) Mark Newcombe: Augusta, ME, Arctic Cat<br />
2) Mike Morris: Turner, ME, Arctic Cat<br />
3) Ryan Sullivan: Auburn, ME, Arctic Cat<br />
4) Daytona Gould: Dexter, ME, Sno Jet<br />
5) Shawn Martin: Turner, ME, Bombardier</p>
<p>Harry&#8217;s Motorsports &amp; Equipment &amp; UniFirst SINGLE CYLINDER MODIFIED &#8212;<br />
1) Mark Newcombe: Augusta, ME, Arctic Cat<br />
2)  Adam Polevenin: Hebron,ME, Arctic Cat<br />
3) Justin Hartford: Wolfeboro, NH,Sno Jet</p>
<p>SnowStuds, Star City Rentals &amp; PowerMadd 340 STOCK &#8212;<br />
1) Justin Hartford: Wolfeboro, NH, Yamaha<br />
2) Daytona Gould: Dexter, ME, Yamaha<br />
3) Mike Morris: Turner, ME, Arctic Cat<br />
4) Landon Collins: Wolfeboro, NH, Yamaha<br />
5) Alley Ripley: West Ossipee, NH, Yamaha</p>
<p>Savage Paint &amp; Body and Dead River Company 340/440 MODIFIED &#8212;<br />
1) Justin Hartford: Wolfeboro, NH, Yamaha<br />
2) Daytona Gould: Dexter, ME, Arctic Cat<br />
3) Shawn Berry: Center Ossipee, NH, Yamaha</p>
<p>Bangor Motorsports &amp; J McLaughlin Construction 440 STOCK<br />
1) Shawn Berry: Center Ossipee, NH, Yamaha<br />
2) Daytona Gould: Dexter, ME, Arctic Cat<br />
3) Alec Hayford: Center Ossipee, NH, Yamaha<br />
4) Caleb Morris: Turner, ME, Arctic Cat<br />
5) Jerry Worden: Ossipee, NH, Yamaha</p>
<p>1st Rate Bait and Pelletier Ford IFS 440 STOCK &#8212;<br />
1) Joe Pelletier: Fort Kent, ME, Arctic Cat<br />
2) Caleb Morris: Turner, ME, Polaris<br />
3) Daytona Gould: Dexter, ME, Arctic Cat</p>
<p>Mission Trailers &amp; Thundering Valley IFS OUTLAW &#8212;<br />
1) Joe Pelletier: Fort Kent, ME, Arctic Cat<br />
2) Daytona Gould: Dexter, ME, Arctic Cat<br />
3) Caleb Morris: Turner, ME, Polaris</p>
<p>The next regularly scheduled race is the Polar Blast race &#8220;First or Last&#8221; &#8211;at the Quincy Field in Stratton/Eustis, Maine. The races will be held on Saturday: February 8th, as part of the Tame the Track Snowmobile Tour regular season schedule.</p>
<p>Go to website: <a href="http://www.tametracktour">www.tametracktour</a> for rules, guidelines, schedules and further information.</p>
<p><span style="color: #ff0000"><em><strong>300 Episode Milestone reached</strong></em></span></p>
<p>When Sports Editor, Joe McLaughlin suggested that I begin a blog for the digital side of the Bangor Daily News in April 2014, I never would have predicted I would still be publishing weekly episodes for five years.</p>
<div id="attachment_1684" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I.jpg"><img class="size-large wp-image-1684" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2016/10/Tony-Ronzio-and-I-300x300.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">At the Maine Press Association&#8217;s 2016 Awards Ceremony in Portland with Bangor Daily News Executive Editor Anthony &#8220;Tony&#8221; Ronzio. HTF Motorsports photo</p></div>
<p>When I received the Maine Press Association award for best blog site in October 2016 I was deeply humbled. When 2019 year ended and we had over a quarter million views in one year, I again was humbled that folks would look at this blog written from a small town in northern Maine! Thank you.</p>
<p>Next weekend is Super Bowl Sunday and we are hosting a drug, alcohol and smoke free Super Bowl watch on the big screen at the Caribou Assembly of God Activity Center on 6 Summer Street in Caribou starting at 6 pm. Free pizza, wings, chips, veggie trays and soda will be offered. At half time a presentation by three Christian football players including Ben Watson of the Patriots will be shown.</p>
<p>I will be spending my evening making sure our guests are well taken care of and probably will not have time to write episode 301. Don&#8217;t forget to subscribe and share UpNorth Motorsports. Look at the end of each episode where you can get sign up for email notifications of each episode.</p>
<p>Let&#8217;s go racing,</p>
<p>Tom Hale</p>
<p>Soli Deo Gloria (Matthew 5:16)</p>
<p>&nbsp;</p>

		</div>
			
			        <script type="text/javascript">
            try {
                _402_Show();
            } catch (e) {
            }
        </script>
	    
			
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Rolex 24 Hours of Daytona  begins Speedweeks 2020."
               data-url="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Rolex-Daytona-Fireworks-2018-Lou-Masciarelli-photo-250x250.jpg&description=Rolex 24 Hours of Daytona  begins Speedweeks 2020" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


	</div><!-- .entry-content -->

	
	<footer class="entry-meta">
	    				                    
<div class="author-info">
	<div class="author-avatar">
			    <img src="http://gravatar.com/avatar/a67b779fa5e32cc5ee2d8c79985865ae?s=74&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F244%2Ffiles%2F2014%2F04%2FIMG_09581-300x300.jpg"
		 alt="Tom Hale"
		 title="Tom Hale"
		 class="gravatar avatar"
		 align="left"
		 width="74" 
		 height="74" 
		 />
	</div><!-- .author-avatar -->
	<div class="author-description">
		<h2 class="author-title">About Tom Hale</h2>
		<p class="author-bio">
			Tom wrote 14 years as  freelancer for the Bangor Daily Sports covering motorsports in Maine. Now blogging and concentrating on human interest stories about people and places in racing. He races Champ Karts and owns HTF Motorsports in remote Westmanland, Maine                    
                        		</p>
	</div><!-- .author-description -->
</div><!-- .author-info -->		    			</footer><!-- .entry-meta -->
</article><!-- #post -->
					<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<a href="http://upnorthmotorsports.bangordailynews.com/2020/01/19/home/maines-griffeth-turf-on-full-display-at-daytona-as-speedweeks-gets-underway/" rel="prev"><span class="meta-nav">&larr;</span> Maine&#8217;s Griffeth turf on full display at Daytona as Speedweeks gets underway</a>			
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	   
		    
				<div class="OUTBRAIN entry-meta" data-src="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" data-widget-id="AR_1" data-ob-template="bangordaily" ></div>
				<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>

				
<div id="comments" class="comments-area comment-respond">
    <div class="comment-list">
            
            <div class="fb-comments" data-href="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" data-colorscheme="light" data-width="604"></div>
            
                        <script>
                jQuery(document).ready(function( $ ) {
                     FB.Event.subscribe('comment.create', function(response) {

                        //Send an email with ajax

                        $.ajax({
                            type: "GET",
                            url: "/wp-admin/admin-ajax.php?action=bdn_facebook_comment_notifications_send",
                            data: { 
                                post_author : "thale@reagan.com", 
                                post_title : "Rolex 24 Hours of Daytona  begins Speedweeks 2020", 
                                post_link : "http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/", 
                                post_id : "4808"
                            }, 
                            dataType: "json",
                            beforeSend:  function() {
                                console.log('Sending message');
                            },
                            success: function(html){
                               console.log('Success sending email');
                               console.log(html);
                            },
                            error: function(html){
                                console.log('There was an error sending the notification email');
                                console.log(html)
                            }
                        });
                     });
                });
               
            </script>
                        
            
            
           
    </div>
</div><!-- #comments -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


	
    <div id="tertiary" class="sidebar-container" role="complementary">
	<div class="sidebar-inner">
	    <div class="widget-area">

		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-top-300x250">
		     <script type="text/javascript">
			  googletag.cmd.push(function() {
				googletag.display("bdnads-blogs-top-300x250");
			   });
		      </script>
		    </div>
		</div>

		<aside id="bdn_blog_bio-2" class="widget widget_bdn_blog_bio"><h3 class="widget-title">                <div class="widget blog-authors">
                    <h3>Tom Hale</h3>
                    <a class="author-avatar" href="">
                        <img src="http://gravatar.com/avatar/a67b779fa5e32cc5ee2d8c79985865ae?s=80&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F244%2Ffiles%2F2014%2F04%2FIMG_09581-300x300.jpg"
                             alt="Tom Hale"
                             title="Tom Hale"
                             class="gravatar avatar"
                             align="left"
                             width="80" 
                             height="80" 
                         />
                    </a>
                    <p>
                        Tom wrote 14 years as  freelancer for the Bangor Daily Sports covering motorsports in Maine. Now blogging and concentrating on human interest stories about people and places in racing. He races Champ Karts and owns HTF Motorsports in remote Westmanland, Maine                    </p>
                    
                                        
                                        
                    
                </div>
                
        </h3></aside><aside id="media_image-2" class="widget widget_media_image"><h3 class="widget-title">Sponsors</h3><a href="http://www.mainerentacar.com/"><img width="200" height="136" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/HTF-ACE-photo-HTF.jpg" class="image wp-image-4656  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></aside><aside id="media_image-3" class="widget widget_media_image"><a href="http://www.smithsfarm.com/"><img width="200" height="200" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer.jpg" class="image wp-image-4657  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer.jpg 200w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer-150x150.jpg 150w" sizes="(max-width: 200px) 100vw, 200px" /></a></aside><aside id="media_image-4" class="widget widget_media_image"><a href="https://maineindoorkarting.com/"><img width="200" height="100" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/HTF-MIK-banner-2.jpg" class="image wp-image-4658  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></aside><aside id="media_image-5" class="widget widget_media_image"><img width="200" height="129" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/HTF-Sponsor-Pine-Tree-Cleaning-and-Restoration-HTF.jpg" class="image wp-image-4659  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></aside>        <div class="bdn-blogs-widget widget category-sports">
            <!--
            Document   : Formerly bdn-blog-promotions.css
            Created on : Sep 16, 2013, 4:43:03 PM
            Author     : Pattie Reaves
            Version	   : 1.1
            Description: Styles the BDN blogs widget.
             -->
            <style>
                .bdn-blog-headshot {
                    width: 70px;
                    height: 70px;
                    -moz-border-radius: 35px;
                    -webkit-border-radius: 35px;
                    border-radius: 35px;
                }

                .bdn-blogs-widget-posts img {
                    margin: 0 10px 10px 0;
                }

                .bdn-blogs-widget-posts {
                    border: #006743 solid 1px;
                    padding: 5px;
                }

                .bdn-blogs-widget-header {
                    overflow: auto;
                    background-color: #006743;
                    color: #fff;
                }

                .bdn-blogs-widget-header img {margin-right: 10px;}
                .bdn-blogs-widget-header h3 {font-size: 50px; clear: right; margin: 10px;}
                .widget .bdn-blogs-widget-header a, .widget .bdn-blogs-widget-header a:visited {color: #fff; line-height: 30px;}

                .blogwidget {
                    margin: 10px 0;
                    padding: 10px 0;
                    overflow: auto;
                    border-bottom: 1px solid #ddd;
                }

                .blogwidget:first-of-type {
                    margin-top: 0;
                }
                .blogwidget:last-of-type {
                    margin-bottom: 0;
                }

                .bdn-blogs-widget-header .promo-links {margin-left: 5px;}

                h4.blogstory, h5.blogname {
                    margin: 0;
                }

                h5.blogname {text-transform: uppercase; font-size: 75%;}

                a.post-image {
                    text-indent: -99999px;
                    display: block;
                    width: 100%;
                    height: 180px;
                    margin-bottom: 5px;
                    background-repeat: no-repeat;
                    background-position: center center;
                    background-color: #ccc;
                }
            </style>
            <div class="bdn-blogs-widget-header">
                <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget">
                    <img src="//bangordailynews.com/wp-content/themes/bdn/images/bdnmaine_110.png" width="60"
                         align="left">
                </a>
                <h3>
                    <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget">
                        Blogs
                    </a>
                </h3>
                <div class="promo-links">
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/be-a-bdn-blogger/">Be a BDN
                        blogger</a> |
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/">Browse BDN blogs</a>
                </div>
            </div>
            <div class="bdn-blogs-widget-posts">
				<!-- Blogs widget served from memcached --><!-- blogs category: sports -->
            <div id="blogwidget_1" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://upnorthmotorsports.bangordailynews.com/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank title="People and events in motorsports">
						Up North Motorsports                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/01/Jason-Griffet-DIS-photo-2020-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://upnorthmotorsports.bangordailynews.com/2020/01/19/home/maines-griffeth-turf-on-full-display-at-daytona-as-speedweeks-gets-underway/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                            title="Maine's Griffeth turf on full display at Daytona as Speedweeks gets underway">
						Maine's Griffeth turf on full display at Daytona as Speedweeks gets underway                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://upnorthmotorsports.bangordailynews.com/2020/01/19/home/maines-griffeth-turf-on-full-display-at-daytona-as-speedweeks-gets-underway/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank>
						Maine's Griffeth turf on full display at Daytona as Speedweeks gets underway                    </a>
                </h4>
            </div>

		            </div>

        </div><!-- /.bdn-blogs-widget -->

		<!-- Blogs widget took 0.004602 seconds to load. -->
		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-bottom-300x250">
			 <script type="text/javascript">
			      googletag.cmd.push(function() {
				    googletag.display("bdnads-blogs-bottom-300x250");
			       });
			  </script>
		    </div>
		</div>
	    </div><!-- .widget-area -->

	</div><!-- .sidebar-inner -->
    </div><!-- #tertiary -->
	
	

		</div><!-- #main -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div id="secondary" class="sidebar-container" role="complementary">
		<div class="widget-area">
			<aside id="blog_subscription-2" class="widget jetpack_subscription_widget"><h3 class="widget-title">Subscribe to Blog via Email</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 26 other subscribers</p>
					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://upnorthmotorsports.bangordailynews.com/2020/01/26/home/rolex-24-hours-of-daytona-begins-speedweeks-2020/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside><aside id="rss_links-2" class="widget widget_rss_links"><h3 class="widget-title">Subscribe via RSS</h3><p><a target="_self" href="http://upnorthmotorsports.bangordailynews.com/feed/" title="Subscribe to Posts"><img src="http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/images/rss/orange-small.png" alt="RSS Feed" /></a>&nbsp;<a target="_self" href="http://upnorthmotorsports.bangordailynews.com/feed/" title="Subscribe to Posts">RSS - Posts</a></p>
</aside><aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="search-form" action="http://upnorthmotorsports.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form></aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='http://upnorthmotorsports.bangordailynews.com/2020/01/'>January 2020</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/12/'>December 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/11/'>November 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/10/'>October 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/09/'>September 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/08/'>August 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/07/'>July 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/06/'>June 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/05/'>May 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/04/'>April 2019</a>&nbsp;(3)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/03/'>March 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/02/'>February 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/01/'>January 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/12/'>December 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/11/'>November 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/10/'>October 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/09/'>September 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/08/'>August 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/07/'>July 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/06/'>June 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/05/'>May 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/04/'>April 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/03/'>March 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/02/'>February 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/01/'>January 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/12/'>December 2017</a>&nbsp;(3)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/11/'>November 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/10/'>October 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/09/'>September 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/08/'>August 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/07/'>July 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/06/'>June 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/05/'>May 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/04/'>April 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/03/'>March 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/02/'>February 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/01/'>January 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/12/'>December 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/11/'>November 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/10/'>October 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/09/'>September 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/08/'>August 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/07/'>July 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/06/'>June 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/05/'>May 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/04/'>April 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/03/'>March 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/02/'>February 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/01/'>January 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/12/'>December 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/11/'>November 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/10/'>October 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/09/'>September 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/08/'>August 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/07/'>July 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/06/'>June 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/05/'>May 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/04/'>April 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/03/'>March 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/02/'>February 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/01/'>January 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/12/'>December 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/11/'>November 2014</a>&nbsp;(3)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/10/'>October 2014</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/09/'>September 2014</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/08/'>August 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/07/'>July 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/06/'>June 2014</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/05/'>May 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/04/'>April 2014</a>&nbsp;(2)</li>
		</ul>
		</aside><aside id="meta-2" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bangordailynews.com/new-account/">Register</a></li>			<li><a href="https://upnorthmotorsports.bangordailynews.com/wp-login.php">Log in</a></li>
			<li><a href="http://upnorthmotorsports.bangordailynews.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://upnorthmotorsports.bangordailynews.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>		</div><!-- .widget-area -->
	</div><!-- #secondary -->

			<div class="site-info">
                            <a href="http://bangordailynews.com/maine-blogs/?utm_source=Up+North+Motorsports&utm_medium=footer">
                                <img src="http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg" width="32" />
                                Up North Motorsports is a member of the BDN Maine Blog network.
                            </a>
			</div><!-- .site-info -->
			
			<!--Desktop only-->
			<div id="footer">
			    <div id="box-wrap">
				<div id="box1">
				    <h1 class="headline">Bangor Daily News</h1>
				    <ul class="sitemap">
					<li><a href="http://archive.bangordailynews.com/">Archives</a></li>
					<li><a href="http://bangordailynews.com/">News</a></li>
					<li><a href="http://bangordailynews.com/business/">Business</a></li>
					<li><a href="http://bangordailynews.com/sports/">Sports</a></li>
					<li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li>
					<li><a href="http://bangordailynews.com/homestead/">Homestead</a></li>
					<li><a href="http://bangordailynews.com/link/tv-listings/">TV Listings</a></li>
					<li><a href="http://obituaries.bangordailynews.com/">Obituaries</a></li>
					<li><a href="http://bangordailynews.com/events/">Things to Do</a></li>
					<li><a href="http://bangordailynews.com/special-sections/">Custom Publications</a></li>
					<li><a href="http://marketplace.bangordailynews.com/?post_type=coupon">Coupons</a></li>
					<li><a href="http://bangordailynews.com/weather/">Weather</a></li>
					<li><a href="http://bangordailynews.com/closings/">Storm Cancellations</a></li>
				    </ul>
				</div><!-- #box1 -->
				<div id="box2">
				    <h1 class="headline">About Us</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/about/">BDN History</a></li>
					<li><a href="http://external.bangordailynews.com/bdn-anniversary/">BDN 120 Years</a></li>
					<li><a href="http://bangordailynews.com/contact">Contact Us</a></li>
					<li><a href="http://store.bangordailynews.com/">Purchase Photos</a></li>
					<li><a href="http://nie.bangordailynews.com/">Newspapers in Education</a></li>
					<li><a href="http://bangordailynews.com/terms-of-service/">Terms of Service</a></li>
					<li><a href="http://bangordailynews.com/privacy/">Privacy Policy</a></li>
				    </ul>
				    <h1 class="headline" style="margin-top: 15px;">Subscribe</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/subscribe/">Bangor Daily News Subscriptions</a></li>
					<li><a href="http://bangordailynews.com/staff/circulation/">Manage Your Subscription</a></li>
					<li><a href="http://bangordailynews.com/newsletters/">Email Updates</a></li>
					<li><a href="http://bangordailynews.com/feed/">RSS</a></li>
				    </ul>
				</div><!-- #box2 -->
				<div id="box3">
				    <h1 class="headline">Sales and Marketing</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/staff/advertising/classifieds/">Classifieds</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Print and Online Advertising</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/special-sections/">Custom Publications and The Weekly</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Advertising Staff Directory</a></li>
					<li><a href="http://creativeservices.bangordailynews.com/guide-to-sending-files/">Creative Services-Guide to Sending Files</a></li>
				    </ul>
				</div><!-- #box3 -->
				<div id="box4">
				    <h1 class="headline">On Facebook</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.facebook.com/bangordailynews" title="The Bangor Daily News on Facebook">The Bangor Daily News</a></li>
                        <li><a href="http://www.facebook.com/bdnmainemidcoast" title="BDN Midcoast on Facebook">Midcoast</a></li>
                        <li><a href="http://www.facebook.com/bdnmaineportland" title="BDN Portland on Facebook">Portland</a></li>
                        <li><a href="http://www.facebook.com/bdnmainearoostook" title="BDN Aroostook on Facebook">Aroostook</a></li>
                        <li><a href="http://www.facebook.com/bdnmainedowneast" title="BDN Midcoast on Facebook">Downeast</a></li>
                        <li><a href="http://www.facebook.com/bdnmainehancock" title="BDN Hancock on Facebook">Hancock</a></li>
                        <li><a href="http://www.facebook.com/pages/BDN-Katahdin-and-Lincoln-Lakes-Region-News/139993822727247" title="BDN Katahdin and Lincoln Lakes Region on Facebook">Katahdin and Lincoln Lakes Region</a></li>
                        <hr />
                        <li><a href="http://www.facebook.com/BDNFoodForThought" title="BDN Food on Facebook">Food</a></li>
                        <li><a href="https://www.facebook.com/bdnmaineoutdoors" title="BDN Outdoors on Facebook">Outdoors</a></li>
                        <li><a href="https://www.facebook.com/BDNMaineFamilies" title="BDN Maine Families on Facebook">Maine Families</a></li>
                        <li><a href="https://www.facebook.com/BDNBlogs" title="BDN Blogs on Facebook">BDN Blogs</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/pages/BDN-Editorial-Opinion/107406425993156" title="BDN Editorial and Opinion on Facebook">Editorial and Opinion</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/bdnmainesports" title="BDN Maine Sports on Facebook">Maine Sports</a></li>
                        <li><a href="https://www.facebook.com/bdnhssports" title="BDN High School Sports on Facebook">High School Sports</a></li>
                    </ul>
                    <h1 class="headline">On Twitter</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.twitter.com/bangordailynews" title="The Bangor Daily News on Twitter">@bangordailynews</a></li>
                        <li><a href="http://www.twitter.com/bdnpolitics" title="The Bangor Daily News on Twitter">@bdnpolitics</a></li>
                        <li><a href="http://www.twitter.com/bdnmaineblogs" title="The Bangor Daily News Blogs on Twitter">@bdnmaineblogs</a></li>
                        <li><a href="http://www.twitter.com/bdnmainefocus" title="The Bangor Daily News Maine Focus on Twitter">@bdnmainefocus</a></li>
                    </ul>
				</div><!-- #box4 -->
			    </div><!--#box-wrap -->
			</div>
			
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W3QLSF"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202005'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/upnorthmotorsports.bangordailynews.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2020Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.6'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/functions.js?ver=2013-07-18'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/out-of-page-ad.js?ver=2018-07-18'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/mu-plugins/js/submitevent.js?ver=2'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202005.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'67503481',post:'4808',tz:'-5',srv:'upnorthmotorsports.bangordailynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '67503481', '4808' ]);
</script>
</body>
</html>
