<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Daytona Speedweeks begins with sheet metal crunching | Up North Motorsports</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://upnorthmotorsports.bangordailynews.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/html5.js"></script>
	<![endif]-->
		<script>
		dataLayer = [{"event":"dataLayer-loaded","companyName":"Bangor Daily News","contentType":"home","author":"Tom Hale","contentPublishedDate":"2020-02-10","contentPublishedTime":"2020-02-10 02:14:53-05:00","lastUpdatedTime":"2020-02-10 07:47:30-05:00","primaryCategory":"Home","allCategories":"Home","visitorIP":"107.23.218.4, 34.226.14.170,10.0.12.99","wordCount":2007}];
	</script>
<script>
	var gtmSetupOptions = {"tagManagerId":"GTM-W3QLSF","autoRun":true};
</script><link rel='dns-prefetch' href='//upnorthmotorsports.bangordailynews.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//bdn-data.s3.amazonaws.com' />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Feed" href="http://upnorthmotorsports.bangordailynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Comments Feed" href="http://upnorthmotorsports.bangordailynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Daytona Speedweeks begins with sheet metal crunching Comments Feed" href="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/upnorthmotorsports.bangordailynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300,400,700,300italic,400italic,700italic|Roboto+Slab:400italic,700italic,400,700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-style-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/style.css?ver=2016-10-24' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/GTM-DataLayer/assets/js/gtm.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='http://upnorthmotorsports.bangordailynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://upnorthmotorsports.bangordailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://upnorthmotorsports.bangordailynews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='John Andretti leaves a legacy of caring' href='http://upnorthmotorsports.bangordailynews.com/2020/02/03/home/john-andretti-leaves-a-legacy-of-caring/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" />
<link rel='shortlink' href='https://wp.me/p4zeJP-1fY' />
<link rel="alternate" type="application/json+oembed" href="http://upnorthmotorsports.bangordailynews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fupnorthmotorsports.bangordailynews.com%2F2020%2F02%2F10%2Fhome%2Fdaytona-speedweeks-begins-with-sheet-metal-crunching%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://upnorthmotorsports.bangordailynews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fupnorthmotorsports.bangordailynews.com%2F2020%2F02%2F10%2Fhome%2Fdaytona-speedweeks-begins-with-sheet-metal-crunching%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>        
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51c20b68617564b1" data-minify="no" ></script>
	<script type="text/javascript">	    
        var addthis_config = {
            data_ga_tracker:'UA-5329647-48',
            data_track_addressbar:false
	    }; 
	    var addthis_share = {
            url: 'https://wp.me/p4zeJP-1fY',
            title: 'Daytona Speedweeks begins with sheet metal crunching',
            templates: {
                twitter: '{{title}}: {{url}} (via @bangordailynews)',
            }
	    };
        
        addthis.layers({
            'theme' : 'transparent',
                'share' : {
                  'position' : 'left',
                  'numPreferredServices' : 4,
                  'services' : "facebook,twitter,pinterest,email,more",
                'postShareFollowMsg' : "Follow Up North Motorsports:",
                  'offset' : {'top' : '320px'}
                }, 
            'follow' : {
              'services' : [
            {'service': 'facebook', 'id': 'bangordailynews'},
            {'service': 'twitter', 'id': 'bangordailynews'},
            {'service': 'rss', 'id': 'http://upnorthmotorsports.bangordailynews.com/feed/'}
              ],
              'offset' : {'top': '30px'}
            },  
            'whatsnext' : {} 
	  });
	  

	</script>
	<!-- AddThis Smart Layers END -->
    
    <!-- Please call pinit.js only once per page -->
    <!--I'm putting this here so it's only called once-->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>
    
    
    <script type="text/javascript">
        var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
        (function () {
	        var gads = document.createElement("script");
	        gads.async = true;
	        gads.type = "text/javascript";
	        var useSSL = "https:" == document.location.protocol;
	        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
	        var node = document.getElementsByTagName("script")[0];
	        node.parentNode.insertBefore(gads, node);
        })();
        </script>
                <script type="text/javascript">
        googletag.cmd.push(function() {
            var pid_value = "daytona-speedweeks-begins-with-sheet-metal-crunching";
	    googletag.defineSlot('/21682974628/bangordailynews', [[300,250], [300,600]], "bdnads-blogs-top-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "top");
	    googletag.defineSlot('/21682974628/bangordailynews', [300,250], "bdnads-blogs-bottom-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "bottom");
        googletag.defineSlot('/21682974628/bangordailynews', [[970,250], [970,90]], "bdnads-blogs-top-leaderboard")
            .addService(googletag.pubads())
            .setTargeting("pos", "top");

                            googletag.defineSlot('/21682974628/bangordailynews', [300,50], "bdnads-blogs-mobile-300x50")
	            .addService(googletag.pubads())
                .setTargeting("pos", "mobile");
	        googletag.defineSlot('/21682974628/bangordailynews', [[300,250]], "bdnads-inline-300x250")
		        .addService(googletag.pubads())
		        .setTargeting("pos", "inline");

        
							googletag.pubads().setTargeting( 'author', 'blog' );
			            googletag.pubads().setTargeting("pid", pid_value);
                        googletag.pubads().setTargeting("kw", ['Up North Motorsports', 'sports', 'blog']);
            googletag.pubads().enableSingleRequest();           
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
	});
	</script>
    	<style type="text/css" id="bdnblog2013-header-css">
			.site-header {
			background: url(http://upnorthmotorsports.bangordailynews.com/files/2014/04/cropped-IMGP0002.jpg) no-repeat scroll top;
			background-size: 1600px auto;
		}
			.site-title,
		.site-description {
			color: #ffffff;
		}
		</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Daytona Speedweeks begins with sheet metal crunching" />
<meta property="og:url" content="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" />
<meta property="og:description" content="Speedweeks is underway in Florida and snowmobile race results from Maine. Spring is coming&#8230;" />
<meta property="article:published_time" content="2020-02-10T07:14:53+00:00" />
<meta property="article:modified_time" content="2020-02-10T12:47:30+00:00" />
<meta property="og:site_name" content="Up North Motorsports" />
<meta property="og:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Erik-Jones-at-Clash-2020-John-Mayhan-photo.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="960" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Daytona Speedweeks begins with sheet metal crunching" />
<meta name="twitter:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Erik-Jones-at-Clash-2020-John-Mayhan-photo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bdnmaineblogs" />
<style type='text/css'>.site-title, .site-description {
text-shadow: 2px 2px #333;
}</style></head>

<body class="post-template-default single single-post postid-4834 single-format-standard single-author sidebar">


		<script type="text/javascript">
	(function() {
	  var ARTICLE_URL = window.location.href;
	  var CONTENT_ID = 'everything';
	  document.write(
	    '<scr'+'ipt '+
	    'src="//survey.g.doubleclick.net/survey?site=_co4sl7ki43vcs'+
	    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	    '&amp;random='+(new Date).getTime()+
	    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	})();
	</script>
    
	 <div id="fb-root"></div>
	 <script>(function(d, s, id) {
			 var js, fjs = d.getElementsByTagName(s)[0];
			 if (d.getElementById(id)) return;
			 js = d.createElement(s); js.id = id;
			 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=748756371893770";
			 fjs.parentNode.insertBefore(js, fjs);
		 }(document, 'script', 'facebook-jssdk'));</script>
    
	<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
            <div class="home-link">
				<a href="http://upnorthmotorsports.bangordailynews.com/" title="Up North Motorsports" rel="home">
					<h1 class="site-title">Up North Motorsports</h1>
                    <h2 class="site-description">People and events in motorsports</h2>
				</a>
                <a class="bdn-link" href="http://bangordailynews.com/maine-blogs/?utm_source=Up+North+Motorsports&utm_medium=footer">
	                <!--                    <img src="-->
	                <!--/images/BDN_Square.jpg" width="32" alt="BDN Maine" title="BDN Maine"/>-->
	                <!--                    Blog-->
	                <img src="http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/images/bdn_blogs_logo.jpg" alt="BDN Maine"
	                     title="BDN Maine"/>
                </a>
            </div>
			<div id="navbar" class="navbar">
				<nav id="site-navigation" class="navigation main-navigation" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
					<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
					<div class="menu-menu-1-container"><ul id="menu-menu-1" class="nav-menu"><li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14"><a href="http://upnorthmotorsports.bangordailynews.com/">Home</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="http://upnorthmotorsports.bangordailynews.com/about-tom/">About Tom</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="http://upnorthmotorsports.bangordailynews.com/contact/">Contact</a></li>
<li id="menu-item-1907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1907"><a href="http://upnorthmotorsports.bangordailynews.com/snowmobile-snox-results-more-from-daytona-and-indianapolis/">Snowmobile SnoX Results, More From Daytona and Indianapolis</a></li>
</ul></div>					<form role="search" method="get" id="searchform" class="search-form" action="http://upnorthmotorsports.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form>				</nav><!-- #site-navigation -->
			</div><!-- #navbar -->
		</header><!-- #masthead -->

                <div class="adSpot widget">
            <div id="bdnads-blogs-oop-interstitial">
                <script type="text/javascript">
                    googletag.cmd.push(function () {
                        googletag.display("bdnads-blogs-oop-interstitial");
                    });
                </script>
            </div>
        </div>
                            <div class="adSpot widget">
                                    <div id="bdnads-blogs-top-leaderboard">
                        <script type="text/javascript">
                            googletag.cmd.push(function () {
                                googletag.display("bdnads-blogs-top-leaderboard");
                            });
                        </script>
                    </div>
                            </div>
            <div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

						
				<article id="post-4834" class="post-4834 post type-post status-publish format-standard has-post-thumbnail hentry category-home">
	<header class="entry-header">
		
            <h1 class="entry-title">Daytona Speedweeks begins with sheet metal crunching</h1>

		
		<div class="entry-meta">
			<span class="date"><a href="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" title="Permalink to Daytona Speedweeks begins with sheet metal crunching" rel="bookmark"><time class="entry-date" datetime="2020-02-10T02:14:53+00:00">February 10, 2020</time></a></span><span class="categories-links"><a href="http://upnorthmotorsports.bangordailynews.com/category/home/" rel="category tag">Home</a></span>					    <div class="author-byline">
			By <a href="http://upnorthmotorsports.bangordailynews.com/author/thale10/" title="Posts by Tom Hale" rel="author">Tom Hale</a>		    </div><!-- /.author-byline -->
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	<div class="entry-content entry">

        
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Daytona Speedweeks begins with sheet metal crunching."
               data-url="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Erik-Jones-at-Clash-2020-John-Mayhan-photo-250x250.jpg&description=Daytona Speedweeks begins with sheet metal crunching" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


		<div class="p402_premium">
			<p>Episode 302</p>
<p>February 9, 2020</p>
<p><span style="color: #ff0000"><em><strong>Daytona Baby! Crashes mark beginning of week.</strong></em></span></p>
<p>Speedweeks is under way at Daytona International Speedway with the ARCA race on Saturday afternoon which was won by Michael Self followed closely by second place Hailie Deegan in her Daytona debut.</p>
<p>Ricky Stenhouse Junior won the Daytona 500 pole on Sunday afternoon in his debut with the JTG Daugherty Racing #47 Camaro. Starting beside him will be Alex Bowman in the Hendricks #88 Chevrolet Camaro. Stenhouse will start the Bluegrass Vacations Duels race #1 from the pole position at 7 pm Thursday February 13. Bowman will start from the pole in duel #2 which begins directly after race number one. These races will determine starting positions for the Daytona 500 on Sunday.</p>
<div id="attachment_4842" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo.jpg"><img class="size-large wp-image-4842" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-768x768.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-150x150.jpg 150w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo-300x300.jpg 300w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Andy-Seuss-at-DIS-ARCA-2020-John-Mayhan-photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">New Hampshire&#8217;s Andy Seuss went for a wild ride on lap one of the ARCA race. This is the front end of his torn up race car. Seuss qualified on the outside pole for the race. (John Mayhan photo)</p></div>
<div id="attachment_4847" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo.jpg"><img class="size-large wp-image-4847" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-768x768.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-150x150.jpg 150w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo-300x300.jpg 300w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneay-stretching-before-Clash-2020-John-Mayhan-photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Tire carrier for the #4 Ford of Kevin Harvick, Mike Morneau, stretching before the 2020 Busch Clash at Daytona International Speedway. (John Mayhan photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Mike Morneau and crew in action during a green flag pit stop during the Busch Clash 2020. Video courtesy John Mayhan.</strong></em></span></p>
<p><a href="https://www.facebook.com/jmayhan/videos/10213088833535122/">https://www.facebook.com/jmayhan/videos/10213088833535122/</a></p>
<p>&nbsp;</p>
<div id="attachment_4844" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo.jpg"><img class="size-large wp-image-4844" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-768x768.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-150x150.jpg 150w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo-300x300.jpg 300w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-car-at-end-of-Clash-2020-John-Mayhan-photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Maine&#8217;s Mike Morneau is a pit crew member of the Kevin Harvick #4 Ford which sustained heavy damage taking him out of the Clash on lap 77. William Byron&#8217;s #24 Chevy Camaro is in background displaying the damage that took him out on lap 74. (John Mayhan photo)</p></div>
<div id="attachment_4846" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo.jpg"><img class="size-large wp-image-4846" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-768x768.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-150x150.jpg 150w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo-300x300.jpg 300w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Harvick-lr-after-clash-2020-John-Mayhan-photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Side view of the #4 Kevin Harvick car after a wild time during the Buch Clash 2020. (John Mayhan photo)</p></div>
<div id="attachment_4845" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo.jpg"><img class="size-large wp-image-4845" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-768x768.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-150x150.jpg 150w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo-300x300.jpg 300w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Mike-Morneau-Joey-Logano-car-after-Clash-2020-John-Mayhan-photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The #22 Penske Ford of Joey Logano showing some of the damage which occurred on lap 78 taking him out of the race. (John Mayhan photo)</p></div>
<div id="attachment_4843" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Racing-Eric-Jones-wins-2020-Busch-Clash-Toyota-racing-photo.jpg"><img class="size-large wp-image-4843" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Racing-Eric-Jones-wins-2020-Busch-Clash-Toyota-racing-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Racing-Eric-Jones-wins-2020-Busch-Clash-Toyota-racing-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Racing-Eric-Jones-wins-2020-Busch-Clash-Toyota-racing-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Racing-Eric-Jones-wins-2020-Busch-Clash-Toyota-racing-photo-768x512.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Joe Gibbs Racing&#8217;s Erik Jones with the help of drafting partner/team-mate Denny Hamlin(one lap down) won the wreck marred Busch Clash which saw only six cars finish of the 18 that started. Jones car shows some of the race damage. (Toyota Racing photo)</p></div>
<p><em><strong>Snowmobile racers prevail despite cold weather</strong></em></p>
<p>Near zero temperatures at the Tame the Track Snowmobile Tour races in Eustis Saturday did not slow down the race teams who must be tough! Fifteen feature races plus heat races were run.</p>
<p>According to Promoter/Race Director Jere Humphrey, &#8221; We had several familiar faces reached the podium this week, a few new first time winners and some veterans returning to the sport after battling fierce competition, all day long.&#8221;</p>
<p>Dysart&#8217;s Truck Stop, Crabbie&#8217;s Racing, KLIM KIDS 120cc STOCK &#8212;<br />
1st place Keegan Reynolds: Hermon, ME, Polaris<br />
2nd place Trenton Hanscom: Benton, ME, Polaris<br />
3rd Place Brannen Keaton: ME, Arctic Cat</p>
<p>Recreational Motorsports &amp; Machias Savings Bank KIDS 120cc IMPROVED/LO 206 &#8212;<br />
1st place Colby Martin: Turner, ME, Polaris<br />
2nd place Aubrey Keaton: ME, Arctic Cat<br />
3rd Place Mason Lavanway: Auburn, ME, Arctic Cat</p>
<p>Witham&#8217;s Paving, Daigle Oil Company KIDS 120cc MODIFIED<br />
1st place Riley Hartford: Wolfeboro, NH, Polaris<br />
2nd place Evan Witham: Levant, ME, NH, Polaris<br />
3rd place Mason Silva: Hudson, ME, Polaris</p>
<div id="attachment_4854" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Cayley-Letourneau-Acoracephotography-permission-granted.jpg"><img class="size-large wp-image-4854" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Cayley-Letourneau-Acoracephotography-permission-granted-600x401.jpg" alt="" width="600" height="401" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Cayley-Letourneau-Acoracephotography-permission-granted-600x401.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Cayley-Letourneau-Acoracephotography-permission-granted-450x301.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Cayley-Letourneau-Acoracephotography-permission-granted-768x513.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Cayley-Letourneau-Acoracephotography-permission-granted.jpg 1440w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Cayleigh Rose, Turner, Maine rode her Arctic Cat to victory in the KIDS 200 Stock class. Photo from the Rangeley Snodeo 2020. (Acorace Photography)</p></div>
<p>Corinth Village Creamery &amp; Willette&#8217;s Automotive KIDS 200 STOCK<br />
1st place Cayleigh Rose: Turner, ME, Arctic Cat<br />
2nd place Kole Alexander: Hermon, ME, Arctic Cat<br />
3rd Place Carley Polvenien: Hebron, ME, Arctic Cat</p>
<div id="attachment_4853" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Katie-Latourneau-at-Eustis-2020-Acorace-Photography.jpg"><img class="size-large wp-image-4853" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Katie-Latourneau-at-Eustis-2020-Acorace-Photography-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Katie-Latourneau-at-Eustis-2020-Acorace-Photography-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Katie-Latourneau-at-Eustis-2020-Acorace-Photography-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Katie-Latourneau-at-Eustis-2020-Acorace-Photography-768x512.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Katie-Latourneau-at-Eustis-2020-Acorace-Photography.jpg 1440w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Katie Letourneau at making her 2020 race debut at Rangeley Snodeo. At the Tame the Track Ladies Invitational in Eustis, she rode her Polaris to a third. She came back from her 2019 race where she rolled her sled three times. (Acorace Photography)</p></div>
<p>Casella Waste Systems/ Pine Tree Waste WOMEN&#8217;S INVITATIONAL &#8212;<br />
1st place Alley Ripley: Center Ossipee, NH Yamaha<br />
2nd place Haley Frohlich: Auburn, ME, Polaris<br />
3rd place Katie Letourneau: Turner, ME, Polaris</p>
<p>TNT Road Company &amp; Last Chance Motorsports JUNIORS INVITATIONAL &#8212;<br />
1st place Riley Hartford: Wolfeboro, NH Yamaha<br />
2nd place Xander Devine: Columbia, NH Yamaha<br />
3rd place Owen Buck: Newport, ME, Yamaha</p>
<p>Workstore and Houlton Powersports &amp; RV TEENS INVITATIONAL &#8212;<br />
1st place Henry Moneypenny: West Ossipee, NH Yamaha<br />
2nd place Asa Grace: West Ossipee, NH Yamaha<br />
3rd place Christian Hanscom: Benton, ME, Yamaha</p>
<div id="attachment_4840" style="width: 518px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-Eustis-Stock-single-class-EAH-photo-2.jpg"><img class="size-large wp-image-4840" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-Eustis-Stock-single-class-EAH-photo-2-508x600.jpg" alt="" width="508" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-Eustis-Stock-single-class-EAH-photo-2-508x600.jpg 508w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-Eustis-Stock-single-class-EAH-photo-2-381x450.jpg 381w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-Eustis-Stock-single-class-EAH-photo-2.jpg 716w" sizes="(max-width: 508px) 100vw, 508px" /></a><p class="wp-caption-text">Stock single class start at 2020 Tame the Track Snowmobile Tour in Eustis, Maine. The race was won by Aroostook County&#8217;s Brandon Ouellette from Fort Kent.(Elizabeth Agnew Hartford photo)</p></div>
<p>Blanchard&#8217;s Towing &amp; VIP Tires SINGLE CYLINDER STOCK<br />
1st place Brandon Ouellette: Fort Kent, ME, Sno Jet<br />
2nd place Daytona Gould: Dexter, ME, Sno Jet<br />
3rd place Jordan Taylor: Kingfield, ME, Arctic Cat<br />
4th place Calvin Rose, Jr: Turner, ME, Arctic Cat<br />
5th place Bob Kent: Mount Vernon, ME, Sno Jet</p>
<p>Harry&#8217;s Motorsports &amp; Equipment &amp; UniFirst SINGLE CYLINDER MODIFIED &#8212;<br />
1st place Adam Polevenin: Hebron, ME, Arctic Cat<br />
2nd place Justin Hartford: Wolfeboro, NH Sno Jet<br />
3rd place Caleb Morris: Turner, ME, Arctic Cat</p>
<p>SnowStuds, Star City Rentals &amp; PowerMadd 340 STOCK &#8212;<br />
1st place Henry Moneypenny: West Ossipee, NH, Yamaha<br />
2nd place Mike Morris: Turner, ME, Arctic Cat<br />
3rd place Daytona Gould: Dexter, ME, Yamaha</p>
<p>Savage Paint &amp; Body and Dead River Company 340/440 MODIFIED &#8212;<br />
1st place Justin Hartford: Wolfeboro, NH,Yamaha<br />
2nd place Daytona Gould: Dexter, ME, Arctic Cat<br />
3rd place Nate Alexander: Orrington, ME, Yamaha</p>
<p>Bangor Motorsports &amp; J McLaughlin Construction 440 STOCK<br />
1st place Caleb Morris: Turner, ME, Arctic Cat<br />
2nd place Jake Bissonnette: Poland, ME, Arctic Cat<br />
3rd place Alley Ripley: Center Ossipee, NH, Yamaha</p>
<div id="attachment_4839" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Hartfords-at-Eustis-awards-EAH-photo-2020-2.jpg"><img class="size-large wp-image-4839" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Hartfords-at-Eustis-awards-EAH-photo-2020-2-600x474.jpg" alt="" width="600" height="474" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Hartfords-at-Eustis-awards-EAH-photo-2020-2-600x474.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Hartfords-at-Eustis-awards-EAH-photo-2020-2-450x356.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Hartfords-at-Eustis-awards-EAH-photo-2020-2-768x607.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-Hartfords-at-Eustis-awards-EAH-photo-2020-2.jpg 849w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Tame the Track awards ceremony at the Hartford table displaying some of their trophies. l to r Riley, Hailey, and Justin Hartford, MacKenzie Gould, Kevin Weeks and Ronnie Weeks seated. Justin Hartford races Ronnie Weeks #22 Ski Doo, the 27 and 66 Sno Jet of Tim Ferreira and Rom Nason, and the #56 Yamaha for Hartford Racing in 340 stock 440 stock and 340/440 modified He placed in 4 classes with over 100 racing laps. Riley placed in 2 classes. (Elizabeth Agnew Hartford photo)</p></div>
<p>1st Rate Bait and Pelletier Ford IFS 440 STOCK &#8212;<br />
1st place Justin Hartford: Wolfeboro, NH, Ski Doo<br />
2nd place Joe Pelletier: Fort Kent, ME, Arctic Cat<br />
3rd place Jake Bissonnette: Poland, ME, Arctic Cat</p>
<p>Mission Trailers &amp; Briarwood Motor Inn IFS OUTLAW &#8212;<br />
1st place Joe Pelletier: Fort Kent, ME, Arctic Cat<br />
2nd place Daytona Gould: Dexter, ME, Arctic Cat<br />
3rd place Caleb Morris: Turner, ME, Polaris</p>
<p>Fort Kent Powersports, Mike&#8217;s &amp; Sons &amp; Jeff&#8217;s Catering Trail 600 Introductory &#8212;<br />
1st place Brandon Ouellette: Fort Kent, ME, Arctic Cat<br />
2nd place Daytona Gould: Dexter, ME, Arctic Cat<br />
3rd place Justin Hartford: Wolfeboro, NH, Ski Doo</p>
<p>The next regularly scheduled race is the combined venue event with the Lincoln Snowhounds race &#8220;Line Em Up&#8221; at the Lincoln SnoCross in Lincoln, Maine which will be held on both Saturday &amp; Sunday: February 22nd/23rd, during the Tame the Track Snowmobile Tour regular season schedule.</p>
<div id="attachment_4837" style="width: 460px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-at-Lincoln-Poster.jpg"><img class="size-large wp-image-4837" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-at-Lincoln-Poster-450x600.jpg" alt="" width="450" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-at-Lincoln-Poster-450x600.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-at-Lincoln-Poster-338x450.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Tame-the-Track-2020-at-Lincoln-Poster.jpg 720w" sizes="(max-width: 450px) 100vw, 450px" /></a><p class="wp-caption-text">Check each organization&#8217;s Facebook page or website for specific information.</p></div>
<p><span style="color: #ff0000"><em><strong>Racer John Andretti take final lap at Indy</strong></em></span></p>
<div id="attachment_4841" style="width: 550px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/John-Andretti-hearse-going-into-turn-one-at-Indy-IMS-photo.jpg"><img class="size-full wp-image-4841" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/John-Andretti-hearse-going-into-turn-one-at-Indy-IMS-photo.jpg" alt="" width="540" height="281" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/John-Andretti-hearse-going-into-turn-one-at-Indy-IMS-photo.jpg 540w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/John-Andretti-hearse-going-into-turn-one-at-Indy-IMS-photo-450x234.jpg 450w" sizes="(max-width: 540px) 100vw, 540px" /></a><p class="wp-caption-text">Entering turn one, Crown Hill Funeral Home hearse bearing the body of 56 year-old John Andretti, who died of colon cancer, takes a final lap of Indianapolis Motor Speedway at his funeral February 6.  (Indianapolis Motor Speedway photo)</p></div>
<p><span style="color: #ff0000"><em><strong>As 2020 drag racing gets under way&#8230;thought you might want to know</strong></em></span></p>
<div id="attachment_4849" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Dragster-tire-under-power-NHRA-photo.jpg"><img class="size-large wp-image-4849" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Dragster-tire-under-power-NHRA-photo-600x338.jpg" alt="" width="600" height="338" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Dragster-tire-under-power-NHRA-photo-600x338.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Dragster-tire-under-power-NHRA-photo-450x253.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Dragster-tire-under-power-NHRA-photo-768x432.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Dragster-tire-under-power-NHRA-photo.jpg 920w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">What 10,000 horsepower does to a top fuel tire at launch. (photo courtesy NHRA.com)</p></div>
<p>TOP FUEL ACCELERATION PUT INTO PERSPECTIVE (Courtesy Damn That&#8217;s Interesting)</p>
<p>* One Top Fuel dragster 500 cubic-inch Hemi engine makes <span class="text_exposed_show">more horsepower (10,000 HP) than the first 5 rows at the Daytona 500.</span></p>
<div class="text_exposed_show">
<p>* Under full throttle, a dragster engine consumes 1.2-1.5 gallons of nitro methane per second; a fully loaded 747 consumes jet fuel at the same rate with 25% less energy being produced.</p>
<p>* A stock Dodge Hemi V8 engine cannot produce enough power to merely drive the dragster&#8217;s supercharger.</p>
<p>* With 3000 CFM of air being rammed in by the supercharger on overdrive, the fuel mixture is compressed into a near-solid form before ignition. Cylinders run on the verge of hydraulic lock at full throttle.</p>
<p>* At the stoichiometric 1.7:1 air/fuel mixture for nitro methane the flame front temperature measures 7050 degrees F.</p>
<p>* Nitromethane burns yellow. The spectacular white flame seen above the stacks at night is raw burning hydrogen, dissociated from atmospheric water vapor by the searing exhaust gases.</p>
<p>* Dual magnetos supply 44 amps to each spark plug.<br />
This is the output of an arc welder in each cylinder.</p>
<p>* Spark plug electrodes are totally consumed during a pass. After 1/2 way, the engine is dieseling from compression plus the glow of exhaust valves at 1400 degrees F. The engine can only be shut down by cutting the fuel flow.</p>
<p>* If spark momentarily fails early in the run, unburned nitro builds up in the affected cylinders and then explodes with sufficient force to blow cylinder heads off the block in pieces or split the block in half.</p>
<p>* Dragsters reach over 300 MPH before you have completed reading this sentence.</p>
<p>* In order to exceed 300 MPH in 4.5 seconds, dragsters must accelerate an average of over 4 G&#8217;s. In order to reach 200 MPH well before half-track, the launch acceleration approaches 8 G&#8217;s.</p>
<p>* Top Fuel engines turn approximately 540 revolutions from light to light!</p>
<p>* Including the burnout, the engine must only survive 900 revolutions under load.</p>
<p>* The redline is actually quite high at 9500 RPM.</p>
<p>* THE BOTTOM LINE: Assuming all the equipment is paid off, the crew worked for free, &amp; for once, NOTHING BLOWS UP, each run costs an estimated $1,000 per second.</p>
<p>0 to 100 MPH in .8 seconds (the first 60 feet of the run)<br />
0 to 200 MPH in 2.2 seconds (the first 350 feet of the run)<br />
6 g-forces at the starting line (nothing accelerates faster on land)<br />
6 negative g-forces upon deployment of twin chutes at 300 MPH. A NHRA Top Fuel Dragster accelerates quicker than any other land vehicle on earth . . quicker than a jet fighter plane . . . quicker than the space shuttle.</p>
<p>The current Top Fuel dragster elapsed time record is 4.420 seconds for the quarter-mile (2004, Doug Kalitta). The top speed record is 337.58 MPH as measured over the last 66&#8242; of the run (2005, Tony Schumacher).</p>
<p>Putting this all into perspective:</p>
<p>You are driving the average $140,000 Lingenfelter twin-turbo powered Corvette Z06. Over a mile up the road, a Top Fuel dragster is staged &amp; ready to launch down a quarter-mile strip as you pass. You have the advantage of a flying start. You run the &#8216;Vette hard up through the gears and blast across the starting line &amp; pass the dragster at an honest 200 MPH. The &#8216;tree&#8217; goes green for both of you at that moment.</p>
<p>The dragster launches &amp; starts after you. You keep your foot down hard, but you hear an incredibly brutal whine that sears your eardrums &amp; within 3 seconds the dragster catches &amp; passes you.<br />
He beats you to the finish line, a quarter-mile away from where you just passed him. Think about it &#8211; from a standing start, the dragster had spotted you 200 MPH &amp; not only caught, but nearly blasted you off the road when he passed you within a mere 1320 foot long race!</p>
<p>That&#8217;s acceleration!</p>
<p><span style="color: #ff0000"><em><strong>Book review of The Art of Race Car Design, by Bob Riley and Jonathan Ingram</strong></em></span></p>
<div id="attachment_2698" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2017/12/DSCN0963.jpg"><img class="size-large wp-image-2698" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2017/12/DSCN0963-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2017/12/DSCN0963-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2017/12/DSCN0963-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2017/12/DSCN0963-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">A quick review of this book read by Philip LaPointe an actual race car designer for Honda. &#8221; Bob Riley had an excellent career in race car design. It&#8217;s amazing how small the design groups were back then. Now it takes teams of engineers as the cars are complicated and refined. It was a very good read.  Riley&#8217;s race car stories opened the door behind the scenes why some drivers and teams excelled&#8221; (HTF Motorsports photo of Riley book)</p></div>
<p>Let&#8217;s go racing!</p>
<p>Tom Hale</p>
<p>Soli Deo Gloria (Matthew 11:28-30)</p>
</div>

		</div>
			
			        <script type="text/javascript">
            try {
                _402_Show();
            } catch (e) {
            }
        </script>
	    
			
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Daytona Speedweeks begins with sheet metal crunching."
               data-url="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Erik-Jones-at-Clash-2020-John-Mayhan-photo-250x250.jpg&description=Daytona Speedweeks begins with sheet metal crunching" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


	</div><!-- .entry-content -->

	
	<footer class="entry-meta">
	    				                    
<div class="author-info">
	<div class="author-avatar">
			    <img src="http://gravatar.com/avatar/a67b779fa5e32cc5ee2d8c79985865ae?s=74&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F244%2Ffiles%2F2014%2F04%2FIMG_09581-300x300.jpg"
		 alt="Tom Hale"
		 title="Tom Hale"
		 class="gravatar avatar"
		 align="left"
		 width="74" 
		 height="74" 
		 />
	</div><!-- .author-avatar -->
	<div class="author-description">
		<h2 class="author-title">About Tom Hale</h2>
		<p class="author-bio">
			Tom wrote 14 years as  freelancer for the Bangor Daily Sports covering motorsports in Maine. Now blogging and concentrating on human interest stories about people and places in racing. He races Champ Karts and owns HTF Motorsports in remote Westmanland, Maine                    
                        		</p>
	</div><!-- .author-description -->
</div><!-- .author-info -->		    			</footer><!-- .entry-meta -->
</article><!-- #post -->
					<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<a href="http://upnorthmotorsports.bangordailynews.com/2020/02/03/home/john-andretti-leaves-a-legacy-of-caring/" rel="prev"><span class="meta-nav">&larr;</span> John Andretti leaves a legacy of caring</a>			
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	   
		    
				<div class="OUTBRAIN entry-meta" data-src="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" data-widget-id="AR_1" data-ob-template="bangordaily" ></div>
				<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>

				
<div id="comments" class="comments-area comment-respond">
    <div class="comment-list">
            
            <div class="fb-comments" data-href="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" data-colorscheme="light" data-width="604"></div>
            
                        <script>
                jQuery(document).ready(function( $ ) {
                     FB.Event.subscribe('comment.create', function(response) {

                        //Send an email with ajax

                        $.ajax({
                            type: "GET",
                            url: "/wp-admin/admin-ajax.php?action=bdn_facebook_comment_notifications_send",
                            data: { 
                                post_author : "thale@reagan.com", 
                                post_title : "Daytona Speedweeks begins with sheet metal crunching", 
                                post_link : "http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/", 
                                post_id : "4834"
                            }, 
                            dataType: "json",
                            beforeSend:  function() {
                                console.log('Sending message');
                            },
                            success: function(html){
                               console.log('Success sending email');
                               console.log(html);
                            },
                            error: function(html){
                                console.log('There was an error sending the notification email');
                                console.log(html)
                            }
                        });
                     });
                });
               
            </script>
                        
            
            
           
    </div>
</div><!-- #comments -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


	
    <div id="tertiary" class="sidebar-container" role="complementary">
	<div class="sidebar-inner">
	    <div class="widget-area">

		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-top-300x250">
		     <script type="text/javascript">
			  googletag.cmd.push(function() {
				googletag.display("bdnads-blogs-top-300x250");
			   });
		      </script>
		    </div>
		</div>

		<aside id="bdn_blog_bio-2" class="widget widget_bdn_blog_bio"><h3 class="widget-title">                <div class="widget blog-authors">
                    <h3>Tom Hale</h3>
                    <a class="author-avatar" href="">
                        <img src="http://gravatar.com/avatar/a67b779fa5e32cc5ee2d8c79985865ae?s=80&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F244%2Ffiles%2F2014%2F04%2FIMG_09581-300x300.jpg"
                             alt="Tom Hale"
                             title="Tom Hale"
                             class="gravatar avatar"
                             align="left"
                             width="80" 
                             height="80" 
                         />
                    </a>
                    <p>
                        Tom wrote 14 years as  freelancer for the Bangor Daily Sports covering motorsports in Maine. Now blogging and concentrating on human interest stories about people and places in racing. He races Champ Karts and owns HTF Motorsports in remote Westmanland, Maine                    </p>
                    
                                        
                                        
                    
                </div>
                
        </h3></aside><aside id="media_image-2" class="widget widget_media_image"><h3 class="widget-title">Sponsors</h3><a href="http://www.mainerentacar.com/"><img width="200" height="136" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/HTF-ACE-photo-HTF.jpg" class="image wp-image-4656  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></aside><aside id="media_image-3" class="widget widget_media_image"><a href="http://www.smithsfarm.com/"><img width="200" height="200" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer.jpg" class="image wp-image-4657  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer.jpg 200w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/Smiths-Farms-flyer-150x150.jpg 150w" sizes="(max-width: 200px) 100vw, 200px" /></a></aside><aside id="media_image-4" class="widget widget_media_image"><a href="https://maineindoorkarting.com/"><img width="200" height="100" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/HTF-MIK-banner-2.jpg" class="image wp-image-4658  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></aside><aside id="media_image-5" class="widget widget_media_image"><img width="200" height="129" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2019/11/HTF-Sponsor-Pine-Tree-Cleaning-and-Restoration-HTF.jpg" class="image wp-image-4659  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></aside>        <div class="bdn-blogs-widget widget category-sports">
            <!--
            Document   : Formerly bdn-blog-promotions.css
            Created on : Sep 16, 2013, 4:43:03 PM
            Author     : Pattie Reaves
            Version	   : 1.1
            Description: Styles the BDN blogs widget.
             -->
            <style>
                .bdn-blog-headshot {
                    width: 70px;
                    height: 70px;
                    -moz-border-radius: 35px;
                    -webkit-border-radius: 35px;
                    border-radius: 35px;
                }

                .bdn-blogs-widget-posts img {
                    margin: 0 10px 10px 0;
                }

                .bdn-blogs-widget-posts {
                    border: #006743 solid 1px;
                    padding: 5px;
                }

                .bdn-blogs-widget-header {
                    overflow: auto;
                    background-color: #006743;
                    color: #fff;
                }

                .bdn-blogs-widget-header img {margin-right: 10px;}
                .bdn-blogs-widget-header h3 {font-size: 50px; clear: right; margin: 10px;}
                .widget .bdn-blogs-widget-header a, .widget .bdn-blogs-widget-header a:visited {color: #fff; line-height: 30px;}

                .blogwidget {
                    margin: 10px 0;
                    padding: 10px 0;
                    overflow: auto;
                    border-bottom: 1px solid #ddd;
                }

                .blogwidget:first-of-type {
                    margin-top: 0;
                }
                .blogwidget:last-of-type {
                    margin-bottom: 0;
                }

                .bdn-blogs-widget-header .promo-links {margin-left: 5px;}

                h4.blogstory, h5.blogname {
                    margin: 0;
                }

                h5.blogname {text-transform: uppercase; font-size: 75%;}

                a.post-image {
                    text-indent: -99999px;
                    display: block;
                    width: 100%;
                    height: 180px;
                    margin-bottom: 5px;
                    background-repeat: no-repeat;
                    background-position: center center;
                    background-color: #ccc;
                }
            </style>
            <div class="bdn-blogs-widget-header">
                <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget">
                    <img src="//bangordailynews.com/wp-content/themes/bdn/images/bdnmaine_110.png" width="60"
                         align="left">
                </a>
                <h3>
                    <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget">
                        Blogs
                    </a>
                </h3>
                <div class="promo-links">
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/be-a-bdn-blogger/">Be a BDN
                        blogger</a> |
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/">Browse BDN blogs</a>
                </div>
            </div>
            <div class="bdn-blogs-widget-posts">
				<!-- Blogs widget served from memcached --><!-- blogs category: sports -->
            <div id="blogwidget_1" class="blogwidget">

                <h5 class="blogname">
                    <a href="https://upnorthmotorsports.bangordailynews.com/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank title="People and events in motorsports">
						Up North Motorsports                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2020/02/Joe-Gibbs-Erik-Jones-at-Clash-2020-John-Mayhan-photo-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="https://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                            title="Daytona Speedweeks begins with sheet metal crunching">
						Daytona Speedweeks begins with sheet metal crunching                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="https://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank>
						Daytona Speedweeks begins with sheet metal crunching                    </a>
                </h4>
            </div>

		            </div>

        </div><!-- /.bdn-blogs-widget -->

		<!-- Blogs widget took 0.006177 seconds to load. -->
		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-bottom-300x250">
			 <script type="text/javascript">
			      googletag.cmd.push(function() {
				    googletag.display("bdnads-blogs-bottom-300x250");
			       });
			  </script>
		    </div>
		</div>
	    </div><!-- .widget-area -->

	</div><!-- .sidebar-inner -->
    </div><!-- #tertiary -->
	
	

		</div><!-- #main -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div id="secondary" class="sidebar-container" role="complementary">
		<div class="widget-area">
			<aside id="blog_subscription-2" class="widget jetpack_subscription_widget"><h3 class="widget-title">Subscribe to Blog via Email</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 26 other subscribers</p>
					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://upnorthmotorsports.bangordailynews.com/2020/02/10/home/daytona-speedweeks-begins-with-sheet-metal-crunching/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside><aside id="rss_links-2" class="widget widget_rss_links"><h3 class="widget-title">Subscribe via RSS</h3><p><a target="_self" href="http://upnorthmotorsports.bangordailynews.com/feed/" title="Subscribe to Posts"><img src="http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/images/rss/orange-small.png" alt="RSS Feed" /></a>&nbsp;<a target="_self" href="http://upnorthmotorsports.bangordailynews.com/feed/" title="Subscribe to Posts">RSS - Posts</a></p>
</aside><aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="search-form" action="http://upnorthmotorsports.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form></aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='http://upnorthmotorsports.bangordailynews.com/2020/02/'>February 2020</a>&nbsp;(2)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2020/01/'>January 2020</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/12/'>December 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/11/'>November 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/10/'>October 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/09/'>September 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/08/'>August 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/07/'>July 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/06/'>June 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/05/'>May 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/04/'>April 2019</a>&nbsp;(3)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/03/'>March 2019</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/02/'>February 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2019/01/'>January 2019</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/12/'>December 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/11/'>November 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/10/'>October 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/09/'>September 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/08/'>August 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/07/'>July 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/06/'>June 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/05/'>May 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/04/'>April 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/03/'>March 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/02/'>February 2018</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2018/01/'>January 2018</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/12/'>December 2017</a>&nbsp;(3)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/11/'>November 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/10/'>October 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/09/'>September 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/08/'>August 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/07/'>July 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/06/'>June 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/05/'>May 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/04/'>April 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/03/'>March 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/02/'>February 2017</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2017/01/'>January 2017</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/12/'>December 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/11/'>November 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/10/'>October 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/09/'>September 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/08/'>August 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/07/'>July 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/06/'>June 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/05/'>May 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/04/'>April 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/03/'>March 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/02/'>February 2016</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2016/01/'>January 2016</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/12/'>December 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/11/'>November 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/10/'>October 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/09/'>September 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/08/'>August 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/07/'>July 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/06/'>June 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/05/'>May 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/04/'>April 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/03/'>March 2015</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/02/'>February 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2015/01/'>January 2015</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/12/'>December 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/11/'>November 2014</a>&nbsp;(3)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/10/'>October 2014</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/09/'>September 2014</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/08/'>August 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/07/'>July 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/06/'>June 2014</a>&nbsp;(4)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/05/'>May 2014</a>&nbsp;(5)</li>
	<li><a href='http://upnorthmotorsports.bangordailynews.com/2014/04/'>April 2014</a>&nbsp;(2)</li>
		</ul>
		</aside><aside id="meta-2" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="http://bangordailynews.com/new-account/">Register</a></li>			<li><a href="https://upnorthmotorsports.bangordailynews.com/wp-login.php">Log in</a></li>
			<li><a href="http://upnorthmotorsports.bangordailynews.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://upnorthmotorsports.bangordailynews.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>		</div><!-- .widget-area -->
	</div><!-- #secondary -->

			<div class="site-info">
                            <a href="http://bangordailynews.com/maine-blogs/?utm_source=Up+North+Motorsports&utm_medium=footer">
                                <img src="http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg" width="32" />
                                Up North Motorsports is a member of the BDN Maine Blog network.
                            </a>
			</div><!-- .site-info -->
			
			<!--Desktop only-->
			<div id="footer">
			    <div id="box-wrap">
				<div id="box1">
				    <h1 class="headline">Bangor Daily News</h1>
				    <ul class="sitemap">
					<li><a href="http://archive.bangordailynews.com/">Archives</a></li>
					<li><a href="http://bangordailynews.com/">News</a></li>
					<li><a href="http://bangordailynews.com/business/">Business</a></li>
					<li><a href="http://bangordailynews.com/sports/">Sports</a></li>
					<li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li>
					<li><a href="http://bangordailynews.com/homestead/">Homestead</a></li>
					<li><a href="http://bangordailynews.com/link/tv-listings/">TV Listings</a></li>
					<li><a href="http://obituaries.bangordailynews.com/">Obituaries</a></li>
					<li><a href="http://bangordailynews.com/events/">Things to Do</a></li>
					<li><a href="http://bangordailynews.com/special-sections/">Custom Publications</a></li>
					<li><a href="http://marketplace.bangordailynews.com/?post_type=coupon">Coupons</a></li>
					<li><a href="http://bangordailynews.com/weather/">Weather</a></li>
					<li><a href="http://bangordailynews.com/closings/">Storm Cancellations</a></li>
				    </ul>
				</div><!-- #box1 -->
				<div id="box2">
				    <h1 class="headline">About Us</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/about/">BDN History</a></li>
					<li><a href="http://external.bangordailynews.com/bdn-anniversary/">BDN 120 Years</a></li>
					<li><a href="http://bangordailynews.com/contact">Contact Us</a></li>
					<li><a href="http://store.bangordailynews.com/">Purchase Photos</a></li>
					<li><a href="http://nie.bangordailynews.com/">Newspapers in Education</a></li>
					<li><a href="http://bangordailynews.com/terms-of-service/">Terms of Service</a></li>
					<li><a href="http://bangordailynews.com/privacy/">Privacy Policy</a></li>
				    </ul>
				    <h1 class="headline" style="margin-top: 15px;">Subscribe</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/subscribe/">Bangor Daily News Subscriptions</a></li>
					<li><a href="http://bangordailynews.com/staff/circulation/">Manage Your Subscription</a></li>
					<li><a href="http://bangordailynews.com/newsletters/">Email Updates</a></li>
					<li><a href="http://bangordailynews.com/feed/">RSS</a></li>
				    </ul>
				</div><!-- #box2 -->
				<div id="box3">
				    <h1 class="headline">Sales and Marketing</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/staff/advertising/classifieds/">Classifieds</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Print and Online Advertising</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/special-sections/">Custom Publications and The Weekly</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Advertising Staff Directory</a></li>
					<li><a href="http://creativeservices.bangordailynews.com/guide-to-sending-files/">Creative Services-Guide to Sending Files</a></li>
				    </ul>
				</div><!-- #box3 -->
				<div id="box4">
				    <h1 class="headline">On Facebook</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.facebook.com/bangordailynews" title="The Bangor Daily News on Facebook">The Bangor Daily News</a></li>
                        <li><a href="http://www.facebook.com/bdnmainemidcoast" title="BDN Midcoast on Facebook">Midcoast</a></li>
                        <li><a href="http://www.facebook.com/bdnmaineportland" title="BDN Portland on Facebook">Portland</a></li>
                        <li><a href="http://www.facebook.com/bdnmainearoostook" title="BDN Aroostook on Facebook">Aroostook</a></li>
                        <li><a href="http://www.facebook.com/bdnmainedowneast" title="BDN Midcoast on Facebook">Downeast</a></li>
                        <li><a href="http://www.facebook.com/bdnmainehancock" title="BDN Hancock on Facebook">Hancock</a></li>
                        <li><a href="http://www.facebook.com/pages/BDN-Katahdin-and-Lincoln-Lakes-Region-News/139993822727247" title="BDN Katahdin and Lincoln Lakes Region on Facebook">Katahdin and Lincoln Lakes Region</a></li>
                        <hr />
                        <li><a href="http://www.facebook.com/BDNFoodForThought" title="BDN Food on Facebook">Food</a></li>
                        <li><a href="https://www.facebook.com/bdnmaineoutdoors" title="BDN Outdoors on Facebook">Outdoors</a></li>
                        <li><a href="https://www.facebook.com/BDNMaineFamilies" title="BDN Maine Families on Facebook">Maine Families</a></li>
                        <li><a href="https://www.facebook.com/BDNBlogs" title="BDN Blogs on Facebook">BDN Blogs</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/pages/BDN-Editorial-Opinion/107406425993156" title="BDN Editorial and Opinion on Facebook">Editorial and Opinion</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/bdnmainesports" title="BDN Maine Sports on Facebook">Maine Sports</a></li>
                        <li><a href="https://www.facebook.com/bdnhssports" title="BDN High School Sports on Facebook">High School Sports</a></li>
                    </ul>
                    <h1 class="headline">On Twitter</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.twitter.com/bangordailynews" title="The Bangor Daily News on Twitter">@bangordailynews</a></li>
                        <li><a href="http://www.twitter.com/bdnpolitics" title="The Bangor Daily News on Twitter">@bdnpolitics</a></li>
                        <li><a href="http://www.twitter.com/bdnmaineblogs" title="The Bangor Daily News Blogs on Twitter">@bdnmaineblogs</a></li>
                        <li><a href="http://www.twitter.com/bdnmainefocus" title="The Bangor Daily News Maine Focus on Twitter">@bdnmainefocus</a></li>
                    </ul>
				</div><!-- #box4 -->
			    </div><!--#box-wrap -->
			</div>
			
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W3QLSF"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202007'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/upnorthmotorsports.bangordailynews.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.6'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/functions.js?ver=2013-07-18'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/out-of-page-ad.js?ver=2018-07-18'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-content/mu-plugins/js/submitevent.js?ver=2'></script>
<script type='text/javascript' src='http://upnorthmotorsports.bangordailynews.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202007.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'67503481',post:'4834',tz:'-5',srv:'upnorthmotorsports.bangordailynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '67503481', '4834' ]);
</script>
</body>
</html>
