<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>2018 in the rear view mirror | Up North Motorsports</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://upnorthmotorsports.bangordailynews.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/html5.js"></script>
	<![endif]-->
	<!-- Google Tag Manager -->
<script type="text/javascript">
    window.dataLayer = window.dataLayer || [];
    window.dataLayer.push({"event":"dataLayer-loaded","companyName":"Bangor Daily News","contentType":"article","author":"Tom Hale","contentPublishedDate":"2018-12-31","contentPublishedTime":"2018-12-31 01:37:08-05:00","lastUpdatedTime":"2018-12-31 01:44:06-05:00","primaryCategory":"Home","allCategories":"Home"});
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-W3QLSF');</script>
<!-- End Google Tag Manager -->
<link rel='dns-prefetch' href='//upnorthmotorsports.bangordailynews.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//bdn-data.s3.amazonaws.com' />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Feed" href="https://upnorthmotorsports.bangordailynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; Comments Feed" href="https://upnorthmotorsports.bangordailynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Up North Motorsports &raquo; 2018 in the rear view mirror Comments Feed" href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/upnorthmotorsports.bangordailynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300,400,700,300italic,400italic,700italic|Roboto+Slab:400italic,700italic,400,700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-style-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/style.css?ver=2016-10-24' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/bdn-plugins/js/audience.js?ver=14'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/bdn-plugins/js/jwplayer-listener.js?ver=20170410.1'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/bdn-plugins/js/youtube-listener.js?ver=20170410.1'></script>
<link rel='https://api.w.org/' href='https://upnorthmotorsports.bangordailynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://upnorthmotorsports.bangordailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://upnorthmotorsports.bangordailynews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='My quest for horsepower' href='https://upnorthmotorsports.bangordailynews.com/2018/12/24/home/my-quest-for-horsepower/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" />
<link rel='shortlink' href='https://wp.me/p4zeJP-YI' />
<link rel="alternate" type="application/json+oembed" href="https://upnorthmotorsports.bangordailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fupnorthmotorsports.bangordailynews.com%2F2018%2F12%2F31%2Fhome%2F2018-in-the-rear-view-mirror%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://upnorthmotorsports.bangordailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fupnorthmotorsports.bangordailynews.com%2F2018%2F12%2F31%2Fhome%2F2018-in-the-rear-view-mirror%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>        
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51c20b68617564b1" data-minify="no" ></script>
	<script type="text/javascript">	    
        var addthis_config = {
            data_ga_tracker:'UA-5329647-48',
            data_track_addressbar:false
	    }; 
	    var addthis_share = {
            url: 'https://wp.me/p4zeJP-YI',
            title: '2018 in the rear view mirror',
            templates: {
                twitter: '{{title}}: {{url}} (via @bangordailynews)',
            }
	    };
        
        addthis.layers({
            'theme' : 'transparent',
                'share' : {
                  'position' : 'left',
                  'numPreferredServices' : 4,
                  'services' : "facebook,twitter,pinterest,email,more",
                'postShareFollowMsg' : "Follow Up North Motorsports:",
                  'offset' : {'top' : '320px'}
                }, 
            'follow' : {
              'services' : [
            {'service': 'facebook', 'id': 'bangordailynews'},
            {'service': 'twitter', 'id': 'bangordailynews'},
            {'service': 'rss', 'id': 'https://upnorthmotorsports.bangordailynews.com/feed/'}
              ],
              'offset' : {'top': '30px'}
            },  
            'whatsnext' : {} 
	  });
	  

	</script>
	<!-- AddThis Smart Layers END -->
    
    <!-- Please call pinit.js only once per page -->
    <!--I'm putting this here so it's only called once-->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>
    
    
    <script type="text/javascript">
        var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
        (function () {
	        var gads = document.createElement("script");
	        gads.async = true;
	        gads.type = "text/javascript";
	        var useSSL = "https:" == document.location.protocol;
	        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
	        var node = document.getElementsByTagName("script")[0];
	        node.parentNode.insertBefore(gads, node);
        })();
        </script>
                <script type="text/javascript">
        googletag.cmd.push(function() {
            var pid_value = "2018-in-the-rear-view-mirror";
	    googletag.defineSlot('/21682974628/bangordailynews', [[300,250], [300,600]], "bdnads-blogs-top-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "top");
	    googletag.defineSlot('/21682974628/bangordailynews', [300,250], "bdnads-blogs-bottom-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "bottom");
        googletag.defineSlot('/21682974628/bangordailynews', [[970,250], [970,90]], "bdnads-blogs-top-leaderboard")
            .addService(googletag.pubads())
            .setTargeting("pos", "top");

                            googletag.defineSlot('/21682974628/bangordailynews', [300,50], "bdnads-blogs-mobile-300x50")
	            .addService(googletag.pubads())
                .setTargeting("pos", "mobile");
	        googletag.defineSlot('/21682974628/bangordailynews', [[300,250]], "bdnads-inline-300x250")
		        .addService(googletag.pubads())
		        .setTargeting("pos", "inline");

        
							googletag.pubads().setTargeting( 'author', 'blog' );
			            googletag.pubads().setTargeting("pid", pid_value);
                        googletag.pubads().setTargeting("kw", ['Up North Motorsports', 'sports', 'blog']);
            googletag.pubads().enableSingleRequest();           
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
	});
	</script>
    	<style type="text/css" id="bdnblog2013-header-css">
			.site-header {
			background: url(https://upnorthmotorsports.bangordailynews.com/files/2014/04/cropped-IMGP0002.jpg) no-repeat scroll top;
			background-size: 1600px auto;
		}
			.site-title,
		.site-description {
			color: #ffffff;
		}
		</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="2018 in the rear view mirror" />
<meta property="og:url" content="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" />
<meta property="og:description" content="Some of my motorsports memories in 2018. Could not include every event, it would be too much to share. Thank you to everyone who helped me in 2018." />
<meta property="article:published_time" content="2018-12-31T06:37:08+00:00" />
<meta property="article:modified_time" content="2018-12-31T06:44:06+00:00" />
<meta property="og:site_name" content="Up North Motorsports" />
<meta property="og:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo.jpg" />
<meta property="og:image:width" content="1800" />
<meta property="og:image:height" content="1200" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="2018 in the rear view mirror" />
<meta name="twitter:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bdnmaineblogs" />

    <script>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-5329647-1', 'auto');        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('send', 'pageview', {
            'dimension1': 'Tom Hale','dimension2': 'post','dimension3': '244.3764','dimension5': 'sports',				'dimension10': '2',
				 
				'dimension11' : 'No tags'

				        }); //ga send

        /**
         * UA-5329647-52 is the id for the new rollup property
         * It is normally only used in the GTM container. It needs to be added here to be able to send video events
         * direct to the property because the current GTM container is not included on mobile.
         */
        ga('create', 'UA-5329647-52', 'auto', 'rollup4video');
    </script>

			<script>

		/**
		* Function that tracks a click on an outbound link in Google Analytics.
		* This function takes a valid URL string as an argument, and uses that URL string
		* as the event label. Setting the transport method to 'beacon' lets the hit be sent
		* using 'navigator.sendBeacon' in browser that support it.
		 * 
		 * @see https://support.google.com/analytics/answer/1136920?hl=en
		*/
		jQuery(function() {
			jQuery('.entry p a').on( 'click', function() {
				ga('send', 'event', 'in-article click', '244.3764', jQuery(this).attr('href'), {
				  'transport': 'beacon'
				});
			});
		});

		
		jQuery(function($) {
		    // Default time delay before checking location
		    var callBackTime = 100;

		    // # px before tracking a reader
		    var readerLocation = 150;

		    // Set some flags for tracking & execution
		    var timer = 0;
		    var scroller = false;
		    var endContent = false;
		    var didComplete = false;

		    // Set some time variables to calculate reading time
		    var startTime = new Date();
		    var beginning = startTime.getTime();
		    var totalTime = 0;

		    // Get some information about the current page
		    var pageTitle = '244.3764';

		    // Track the aticle load
	        ga('send', 'event', 'Reading', 'ArticleLoaded', pageTitle, {'nonInteraction': 1});


		    // Check the location and track user
		    function trackLocation() {
		        bottom = jQuery(window).height() + jQuery(window).scrollTop();
		        height = jQuery(document).height();

		        // If user starts to scroll send an event
		        if (bottom > readerLocation && !scroller) {
		            currentTime = new Date();
		            scrollStart = currentTime.getTime();
		            timeToScroll = Math.round((scrollStart - beginning) / 1000);

		            ga('send', 'event', 'Reading', 'StartReading', pageTitle, timeToScroll);
		            scroller = true;
		        }

		        // If user has hit the bottom of the content send an event
		        if (bottom >= jQuery('.entry').offset().top + jQuery('.entry').innerHeight() && !endContent) {
		            currentTime = new Date();
		            contentScrollEnd = currentTime.getTime();
		            timeToContentEnd = Math.round((contentScrollEnd - scrollStart) / 1000);
		            ga('send', 'event', 'Reading', 'ContentBottom', pageTitle, timeToContentEnd);
		            endContent = true;
		        }

		        // If user has hit the bottom of page send an event
		        if (bottom >= height && !didComplete) {
		            currentTime = new Date();
		            end = currentTime.getTime();
		            totalTime = Math.round((end - scrollStart) / 1000);

	                if (totalTime < 60) {
	                	ga('set', 'dimension8', 'Scanner');
	                } else {
	                	ga('set', 'dimension8', 'Reader');
	                }

	                ga('send', 'event', 'Reading', 'PageBottom', pageTitle, totalTime);
		            didComplete = true;
		        }
		    }

		    // Track the scrolling and track location
		    jQuery(window).scroll(function() {
		        if (timer) {
		            clearTimeout(timer);
		        }

		        // Use a buffer so we don't call trackLocation too often.
		        timer = setTimeout(trackLocation, callBackTime);
		    });


		});

		</script>

	
<style type='text/css'>.site-title, .site-description {
text-shadow: 2px 2px #333;
}</style>
	<script type="text/javascript">
	var BdnAdsCommandArray = new Array();
	</script>
</head>

<body class="post-template-default single single-post postid-3764 single-format-standard single-author sidebar">


		<script type="text/javascript">
	(function() {
	  var ARTICLE_URL = window.location.href;
	  var CONTENT_ID = 'everything';
	  document.write(
	    '<scr'+'ipt '+
	    'src="//survey.g.doubleclick.net/survey?site=_co4sl7ki43vcs'+
	    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	    '&amp;random='+(new Date).getTime()+
	    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	})();
	</script>
    
	 <div id="fb-root"></div>
	 <script>(function(d, s, id) {
			 var js, fjs = d.getElementsByTagName(s)[0];
			 if (d.getElementById(id)) return;
			 js = d.createElement(s); js.id = id;
			 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=748756371893770";
			 fjs.parentNode.insertBefore(js, fjs);
		 }(document, 'script', 'facebook-jssdk'));</script>
    
	<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
            <div class="home-link">
				<a href="https://upnorthmotorsports.bangordailynews.com/" title="Up North Motorsports" rel="home">
					<h1 class="site-title">Up North Motorsports</h1>
                    <h2 class="site-description">People and events in motorsports</h2>
				</a>
                <a class="bdn-link" href="http://bangordailynews.com/maine-blogs/?utm_source=Up+North+Motorsports&utm_medium=footer">
	                <!--                    <img src="-->
	                <!--/images/BDN_Square.jpg" width="32" alt="BDN Maine" title="BDN Maine"/>-->
	                <!--                    Blog-->
	                <img src="https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/images/bdn_blogs_logo.jpg" alt="BDN Maine"
	                     title="BDN Maine"/>
                </a>
            </div>
			<div id="navbar" class="navbar">
				<nav id="site-navigation" class="navigation main-navigation" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
					<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
					<div class="menu-menu-1-container"><ul id="menu-menu-1" class="nav-menu"><li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14"><a href="http://upnorthmotorsports.bangordailynews.com/">Home</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15"><a href="https://upnorthmotorsports.bangordailynews.com/about-tom/">About Tom</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16"><a href="https://upnorthmotorsports.bangordailynews.com/contact/">Contact</a></li>
<li id="menu-item-1907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1907"><a href="https://upnorthmotorsports.bangordailynews.com/snowmobile-snox-results-more-from-daytona-and-indianapolis/">Snowmobile SnoX Results, More From Daytona and Indianapolis</a></li>
</ul></div>					<form role="search" method="get" id="searchform" class="search-form" action="https://upnorthmotorsports.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form>				</nav><!-- #site-navigation -->
			</div><!-- #navbar -->
		</header><!-- #masthead -->

                <div class="adSpot widget">
            <div id="bdnads-blogs-oop-interstitial">
                <script type="text/javascript">
                    googletag.cmd.push(function () {
                        googletag.display("bdnads-blogs-oop-interstitial");
                    });
                </script>
            </div>
        </div>
                            <div class="adSpot widget">
                                    <div id="bdnads-blogs-top-leaderboard">
                        <script type="text/javascript">
                            googletag.cmd.push(function () {
                                googletag.display("bdnads-blogs-top-leaderboard");
                            });
                        </script>
                    </div>
                            </div>
            <div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

						
				<article id="post-3764" class="post-3764 post type-post status-publish format-standard has-post-thumbnail hentry category-home">
	<header class="entry-header">
		
            <h1 class="entry-title">2018 in the rear view mirror</h1>

		
		<div class="entry-meta">
			<span class="date"><a href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" title="Permalink to 2018 in the rear view mirror" rel="bookmark"><time class="entry-date" datetime="2018-12-31T01:37:08+00:00">December 31, 2018</time></a></span><span class="categories-links"><a href="https://upnorthmotorsports.bangordailynews.com/category/home/" rel="category tag">Home</a></span>					    <div class="author-byline">
			By <a href="https://upnorthmotorsports.bangordailynews.com/author/thale10/" title="Posts by Tom Hale" rel="author">Tom Hale</a>		    </div><!-- /.author-byline -->
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	<div class="entry-content entry">

        
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="2018 in the rear view mirror."
               data-url="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-250x250.jpg&description=2018 in the rear view mirror" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


		<div class="p402_premium">
			<p>Episode 245</p>
<p>December 30, 2018</p>
<p><span style="color: #ff0000"><em><strong>Highlights of 2018</strong></em></span></p>
<p>I must confess, I am not a fan of top ten lists or highlights lists. I might scan them or not read them at all. If I have something in common with someone&#8217;s list I might read it for content.</p>
<p>Thus my dilemma. I want you to be able to flashback over 2018 and maybe rub shoulders with me as I take a trip down memory lane. I would love to have you share your highlights with me keeping in mind that I scan. Email or comments on the post on Facebook seem to be the best. My email <a href="thale@reagan.com">thale@reagan.com</a></p>
<p>My posts are not from top to bottom or vice versa. They are what I wrote down as they came back to me while viewing photos from this year&#8217;s episodes.</p>
<p><em style="color: #ff0000"><strong>Firecracker 200 at Spud Speedway</strong></em></p>
<p>Maybe it was the fact that preparation for this event consumed so much of my time up to and including the day of the July 3rd race. The amount of work that went into getting the track ready for this event was at times overwhelming. Yet through perseverance and grit (and a boatload of Troy Haney&#8217;s money) the event proved to be a classic.</p>
<p>I believe when people look back on Spud Speedway history, the Firecracker 200 will be one remembered. The fact that no races of that nature had been run for several years plus the involvement of Aroostook Savings and Loan, Feed the County, WAGM TV, Pro All Star Series (PASS), and the return of local racers Kirk Thibeau, Wyatt Alexander Racing, and Austin Theriault combined to add to the excitement felt that warm summer evening.</p>
<div id="attachment_3765" style="width: 460px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-crowd-shot-FC-200-July-3-2018-SS-photo.jpg"><img class="wp-image-3765 size-large" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-crowd-shot-FC-200-July-3-2018-SS-photo-450x600.jpg" alt="" width="450" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-crowd-shot-FC-200-July-3-2018-SS-photo-450x600.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-crowd-shot-FC-200-July-3-2018-SS-photo-338x450.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-crowd-shot-FC-200-July-3-2018-SS-photo.jpg 720w" sizes="(max-width: 450px) 100vw, 450px" /></a><p class="wp-caption-text">One of the largest crowds attracted to the Caribou track in many years was the Firecracker 200. Estimates put crowd size at over 2000. (Spud Speedway photo)</p></div>
<div id="attachment_3766" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-Dixie-Shaw-and-Terry-Theriault-HTF-Moto.jpg"><img class="size-large wp-image-3766" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-Dixie-Shaw-and-Terry-Theriault-HTF-Moto-600x399.jpg" alt="" width="600" height="399" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-Dixie-Shaw-and-Terry-Theriault-HTF-Moto-600x399.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-Dixie-Shaw-and-Terry-Theriault-HTF-Moto-450x299.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-Dixie-Shaw-and-Terry-Theriault-HTF-Moto-768x511.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Dixie Shaw (left) with Catholic Charities and the Feed the County project conversing with Austin Theriault&#8217;s mother Terry prior to the races. Feed the County was able to raise over $10,000 at the race. This involvement seemed to bring the community together. (HTF Motorsports photo)</p></div>
<div id="attachment_3767" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-2018-Amy-Harrop-with-Kirk-Thibeau-HTF-Moto-.jpg"><img class="size-large wp-image-3767" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-2018-Amy-Harrop-with-Kirk-Thibeau-HTF-Moto--600x399.jpg" alt="" width="600" height="399" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-2018-Amy-Harrop-with-Kirk-Thibeau-HTF-Moto--600x399.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-2018-Amy-Harrop-with-Kirk-Thibeau-HTF-Moto--450x299.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Spud-Speedway-FC200-2018-Amy-Harrop-with-Kirk-Thibeau-HTF-Moto--768x511.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The only PASS racer living in the County, Kirk Thibeau living in Presque Isle, seen here being interviewed by Amy Hinton-Harrop of Chasing the Checkered online racing publication owner/editor and co-host of Mainely Motorsports TV. Thibeau finished 11th in the race. (HTF Motorsports photo)</p></div>
<div id="attachment_3768" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Austin-T-and-I-Black-Dot-Photo.jpg"><img class="size-large wp-image-3768" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Austin-T-and-I-Black-Dot-Photo-600x480.jpg" alt="" width="600" height="480" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Austin-T-and-I-Black-Dot-Photo-600x480.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Austin-T-and-I-Black-Dot-Photo-450x360.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Austin-T-and-I-Black-Dot-Photo-768x614.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Austin-T-and-I-Black-Dot-Photo.jpg 1398w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Though Austin Theriault dropped out of the race early, he spent time in the announcer&#8217;s booth and with fans until every autograph was signed and photo demand was met. The big mystery for me in 2018 was why Austin had not landed sponsorship for any NASCAR involvement???? (Black Dot Photography)</p></div>
<div id="attachment_3769" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-at-Firecracker-200-Black-Dot-photo.jpg"><img class="size-large wp-image-3769" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-at-Firecracker-200-Black-Dot-photo-600x337.jpg" alt="" width="600" height="337" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-at-Firecracker-200-Black-Dot-photo-600x337.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-at-Firecracker-200-Black-Dot-photo-450x252.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-at-Firecracker-200-Black-Dot-photo-768x431.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Wyatt Alexander Racing #96, another race team with close Spud Speedway connections finished 7th. Alexander was also named the Valvoline Fast Track to Fame national winner. It was interesting to see how the team utilized the support provided to them by Valvoline throughout the year. (Black Dot Photography)</p></div>
<p><span style="color: #ff0000"><em><strong>Rolex 24 Hours of Daytona for the third time</strong></em></span></p>
<p>Three years ago, I decided to cover some sort of racing in Daytona. One of my former students, Jason Griffeth moved from the assistant groundskeeper at Fenway Park after 14.5 years to take the Director of Grounds job at Daytona International Speedway in 2016. His move plus the fact that my brother lives nearby seemed to make sense to cover the Rolex 24 Hours race in January.</p>
<p>I did not want to cover the Daytona 500 with its huge crowds. So I decided to cover the IMSA racing for my first time. I liked it very much with the somewhat smaller crowds, access to drivers and crew pretty well-managed, and race friendly fans.</p>
<p>I hope to return this year for my fourth go-around. I have a local story about a team in the top class, Daytona Prototypes International (DPi) that I hope to release before the race and cover while I am at the track.</p>
<div id="attachment_3771" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo.jpg"><img class="size-large wp-image-3771" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-768x512.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Head of Grounds, Jason Griffeth and his crew, produced and developed this front stretch likeness of the Sir Malcolm Campbell Bluebird streamliner that set records on the beach at Daytona in the 1920&#8217;s and &#8217;30&#8217;s. (Daytona International Speedway photo)</p></div>
<div id="attachment_3772" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-race-2018-VC-Mustang-Sampling-winner-overall-HTF-Moto-.jpg"><img class="size-large wp-image-3772" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-race-2018-VC-Mustang-Sampling-winner-overall-HTF-Moto--600x399.jpg" alt="" width="600" height="399" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-race-2018-VC-Mustang-Sampling-winner-overall-HTF-Moto--600x399.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-race-2018-VC-Mustang-Sampling-winner-overall-HTF-Moto--450x299.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-race-2018-VC-Mustang-Sampling-winner-overall-HTF-Moto--768x511.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">This year&#8217;s Rolex 24 Hours of Daytona was my  first Gatorade Victory Circle photo opportunity when the winner the Mustang Sampling Cadillac DPi won the race with co-drivers Joao Barbosa, Filipe Albuquerque and Christian Fittipaldi.(HTF Motorsports photo)</p></div>
<div id="attachment_3774" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-Hours-2018-Acura-Bill-Hale-photo.jpg"><img class="size-large wp-image-3774" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-Hours-2018-Acura-Bill-Hale-photo-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-Hours-2018-Acura-Bill-Hale-photo-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-Hours-2018-Acura-Bill-Hale-photo-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-24-Hours-2018-Acura-Bill-Hale-photo-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The debut of the Penske Acura team was the talk of the race previews. At one point they lead 1-2. They both fell back due to on track incidents. The number 6 Acura  pictured here after the race placed ninth, fifteen laps to the rear. (Bill Hale photo)</p></div>
<div id="attachment_3776" style="width: 460px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-Austin-Cindric-Chase-Briscoe-and-I-at-Daytona-2018.jpg"><img class="wp-image-3776 size-large" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-Austin-Cindric-Chase-Briscoe-and-I-at-Daytona-2018-450x600.jpg" alt="" width="450" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-Austin-Cindric-Chase-Briscoe-and-I-at-Daytona-2018-450x600.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-Austin-Cindric-Chase-Briscoe-and-I-at-Daytona-2018-338x450.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Daytona-Austin-Cindric-Chase-Briscoe-and-I-at-Daytona-2018.jpg 480w" sizes="(max-width: 450px) 100vw, 450px" /></a><p class="wp-caption-text">Pre-race with Ford guys Austin Cindric and Chase Briscoe. ironic that I was wearing my 2017 ARCA Champ Austin Theriault hat. He has raced and beaten those guys several times. (Bill Hale photo)</p></div>
<div id="attachment_3777" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ford-GT-GTLM-Winners-at-Daytona.-Ford-Performance-photo.jpg"><img class="size-large wp-image-3777" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ford-GT-GTLM-Winners-at-Daytona.-Ford-Performance-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ford-GT-GTLM-Winners-at-Daytona.-Ford-Performance-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ford-GT-GTLM-Winners-at-Daytona.-Ford-Performance-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ford-GT-GTLM-Winners-at-Daytona.-Ford-Performance-photo-768x512.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ford-GT-GTLM-Winners-at-Daytona.-Ford-Performance-photo.jpg 1200w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">GTLM Winners were the Ganassi Ford GT team # 67 driven by Ryan Briscoe, Scott Dixon, and Richard Westbrook. They were followed by Ford GT # 66 driven by Sebastien Bourdais, Joey Hand, and Dirk Muller. This was Chip Ganassi Racing&#8217;s 200th victory. (Ford Performance photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Ripchair built for Mike</strong></em></span></p>
<p>A family ski trip to Deer Valley Ski Resort 11 years ago forever changed Presque Isle native Mike Chasse. Here is what happened in his words as told to NewsCenter Maine&#8217;s Rob Nesbitt in April, &#8220;&#8221;Skiing off into the woods and I went to get back on the main trail and there was a real abrupt, like a real steep angle and my skis hit the side of the trail and stopped and my head just plunged into the ground,&#8221; said Chasse.</p>
<p>Chasse spent months in the hospital and in physical therapy to adjust to being a quadriplegic. Until one year ago he thought he would be relegated to spectator status when it came to getting to some of his favorite places he enjoyed as a younger man.</p>
<p>In early 2017, a group of friends on Facebook called &#8220;Keep Mike Rolling&#8221; led by sisters Brianna Blanchard-Rogerson and Billi Blanchard-Griffeth began fundraising to make up a $10,000 shortfall Chasse was facing. He needed to replace his aging worn out wheelchair which would require him to spend the funds beyond which he had saved to purchase the new chair.</p>
<p>The fundraiser was a huge success. On March 2, 2017, the day after the 10th anniversary of his accident, the group surprised Chasse with over $28,000 to use anyway he wanted. That is where Howe and Howe Technology came into the picture.</p>
<p>This high performance specialty  off-road vehicle manufacturer in Waterboro began their 45th Ripchair made just for Mike Chasse January 2018. I detailed the Ripchair story in Episodes 208 April 15, 2018, 206 April 1, 2018, and 202 on March 4, 2018.</p>
<div id="attachment_3778" style="width: 348px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Mike-Chasse-RipChair-Feb-2018-Howe-Howe-photo.jpg"><img class="wp-image-3778 size-large" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Mike-Chasse-RipChair-Feb-2018-Howe-Howe-photo-338x600.jpg" alt="" width="338" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Mike-Chasse-RipChair-Feb-2018-Howe-Howe-photo-338x600.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Mike-Chasse-RipChair-Feb-2018-Howe-Howe-photo-253x450.jpg 253w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Mike-Chasse-RipChair-Feb-2018-Howe-Howe-photo.jpg 540w" sizes="(max-width: 338px) 100vw, 338px" /></a><p class="wp-caption-text">Mike Chasse Ripchair #45 begins its life at Howe &amp; Howe Technology January 2018. (Howe &amp; Howe photo)</p></div>
<p>In early April 2018, Chasse, caregiver Heidi, and brother-in-law Andrew Bouchard ventured to Waterboro where he laid eyes on his new machine. Chasse said he saw a place he would like to go off-road and for the first time in over a decade was able to make that possible with his new Ripchair.</p>
<div id="attachment_3779" style="width: 730px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ripchair-in-action-Heidi-photo.jpg"><img class="wp-image-3779 size-full" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ripchair-in-action-Heidi-photo.jpg" alt="" width="720" height="960" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ripchair-in-action-Heidi-photo.jpg 720w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ripchair-in-action-Heidi-photo-338x450.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ripchair-in-action-Heidi-photo-450x600.jpg 450w" sizes="(max-width: 720px) 100vw, 720px" /></a><p class="wp-caption-text">Chasse with his Ripchair on its maiden voyage at Howe &amp; Howe Technologies. Though I was unable to connect with Mike on one of his Ripchair adventures in 2018, I hope to be able to do so in 2019.(Photo by Heidi Howlett)</p></div>
<p><span style="color: #ff0000"><em><strong>Tom Peters Inducted into the Maine Motorsports Hall of Fame</strong></em></span></p>
<p>Tom Peters of Presque Isle became the first snowmobile racer inducted into the Maine Motorsports Hall of Fame in a ceremony held at the Augusta Civic Center April 14, 2018 as detailed in Episode 208.</p>
<p>Peters was one of Maine&#8217;s winningest racers in the late 60&#8217;s and into early 70&#8217;s. He currently restores sleds from the era including some that are similar to the race sleds that he drove.</p>
<div id="attachment_3781" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-and-family-MMHF-Ceremony-2018.jpg"><img class="size-large wp-image-3781" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-and-family-MMHF-Ceremony-2018-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-and-family-MMHF-Ceremony-2018-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-and-family-MMHF-Ceremony-2018-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-and-family-MMHF-Ceremony-2018-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">The twelve members of the Peters family at the 2018 Maine Motorsports Hall of Fame Induction Ceremony. Back row left to right, Jennifer Peters, Izabell Peters, Lisa Currie, Carmen and Sadie Robillard, Wendy Peters, Emma Robillard, Charlotte Vaillancourt, Xane Peters, and Tom Peters II. Front row Diane and Tom Peters. (HTF Motorsports photo)</p></div>
<div id="attachment_3782" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-at-show-in-someplaceTP-Photo.jpg"><img class="size-large wp-image-3782" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-at-show-in-someplaceTP-Photo-600x449.jpg" alt="" width="600" height="449" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-at-show-in-someplaceTP-Photo-600x449.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-at-show-in-someplaceTP-Photo-450x337.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-at-show-in-someplaceTP-Photo-768x574.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Tom-Peters-at-show-in-someplaceTP-Photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Immaculately restored sleds and actual driving suit worn by Peters on display at one of the numerous shows that he attends to help keep the memories of racing alive. (Tom Peters photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Harvey, New Brunswick teenager wins Maritimes most prestigious race.</strong></em></span></p>
<p>After losing the season&#8217;s point championship by a tie-breaker to Dave O&#8217;Blenis who had more feature wins and getting the front end of his Pro Stock roughed up in the process, the RYAN Motorsports team came roaring back to win their biggest pay roll at the 18th Annual McLaughlin Roof Trusses 250 at Speedway 660 in Geary Woods, New Brunswick. (Episode 228 September 2, 2018)</p>
<p>This team was moving back down to Late Model Sportsman for 2018 when they had a change of heart in mid-winter 2018. The RYAN Motorsports team decided to compete for a second season in Speedway 660&#8217;s top division after winning Rookie of the year in 2017. The finances were a big concern for the small team from Harvey, New Brunswick.</p>
<p>Episode 229 on September 9, 2019 details some of the highs and lows the team experienced at the end of the season.</p>
<div id="attachment_3783" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ryan-Messer-and-parent-in-2018-Victory-Circle-RYAN-Motorsports-photo.jpg"><img class="size-large wp-image-3783" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ryan-Messer-and-parent-in-2018-Victory-Circle-RYAN-Motorsports-photo-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ryan-Messer-and-parent-in-2018-Victory-Circle-RYAN-Motorsports-photo-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ryan-Messer-and-parent-in-2018-Victory-Circle-RYAN-Motorsports-photo-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Ryan-Messer-and-parent-in-2018-Victory-Circle-RYAN-Motorsports-photo-768x512.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Ryan Messer at age 17 won one of the Maritimes most prestigious races, the 18th Annual McLaughlin Roof Trusses 250 and the $15,850 check that accompanied it. Pictured in Victory Circle at Speedway 660 is Messer with his parents Penny and Robb. Robb is also the crew chief. (RYAN Motorsports photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Kody Swanson wins five races in a row and his fourth USAC Silver Crown title</strong></em></span></p>
<p>Followers of UpNorth Motorsports realize that I cover the career of one of my friends, Kody Swanson from Kingsburg, California now living in Indianapolis, Indiana. He is currently the 2018 USAC Silver Crown Champion, a title he has won in 2014, 2015, and 2017.</p>
<p>Swanson went on a tear this spring and summer winning an unprecedented 5 USAC Silver Crown races in a row:</p>
<ul>
<li>May 4 Toledo Speedway, Toledo, Ohio (.5 mile paved)</li>
<li>May 24 Indiana State Fairgrounds, Indianapolis, Indiana (I mile dirt)</li>
<li>May 25 Lucas Oil Raceway, Indianapolis, Indiana (.686 mile paved)</li>
<li>June 29 Madison International Speedway, Oregon, Wisconsin (.5 mile paved)</li>
<li>August 11 Salem Speedway, Salem, Indiana (.555 mile paved)</li>
</ul>
<p>Providing a bookend May 24 and 25 USAC races was a win for Gene Nolen Racing (his first Little 500 win as an owner) on Saturday May 26th at Anderson Speedway, Anderson, Indiana in the 70th Little 500. Anderson Speedway is a high banked 1/4 mile oval with 33 starters.</p>
<div id="attachment_3784" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-family-and-Gene-Nolen-at-Anderson-photo-by-Darrell-Harper.jpg"><img class="size-large wp-image-3784" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-family-and-Gene-Nolen-at-Anderson-photo-by-Darrell-Harper-600x429.jpg" alt="" width="600" height="429" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-family-and-Gene-Nolen-at-Anderson-photo-by-Darrell-Harper-600x429.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-family-and-Gene-Nolen-at-Anderson-photo-by-Darrell-Harper-450x321.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-family-and-Gene-Nolen-at-Anderson-photo-by-Darrell-Harper-768x549.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Kody Swanson in Victory Circle after winning the 70th Little 500 at Anderson Speedway. Left to right owner Gene Nolen, Swanson, Trevor his son and Jordan his wife and spotter. (Darrell Harper photo)</p></div>
<div id="attachment_3785" style="width: 460px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Jordan-Trevor-and-Adam-Oct-17-2018.jpg"><img class="size-large wp-image-3785" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Jordan-Trevor-and-Adam-Oct-17-2018-450x600.jpg" alt="" width="450" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Jordan-Trevor-and-Adam-Oct-17-2018-450x600.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Jordan-Trevor-and-Adam-Oct-17-2018-338x450.jpg 338w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Jordan-Trevor-and-Adam-Oct-17-2018.jpg 720w" sizes="(max-width: 450px) 100vw, 450px" /></a><p class="wp-caption-text">A highlight for the Swanson family was the birth of second son Adam on October 17, 2018. (Jordan Swanson photo)</p></div>
<div id="attachment_3786" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Bob-Hampshire-at-LOR-2018-Richard-Golardi-photo-1.jpg"><img class="size-large wp-image-3786" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Bob-Hampshire-at-LOR-2018-Richard-Golardi-photo-1-600x400.jpg" alt="" width="600" height="400" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Bob-Hampshire-at-LOR-2018-Richard-Golardi-photo-1-600x400.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Bob-Hampshire-at-LOR-2018-Richard-Golardi-photo-1-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Kody-Swanson-with-Bob-Hampshire-at-LOR-2018-Richard-Golardi-photo-1-768x512.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Kody Swanson on right with retiring car owner Bob Hampshire in the midst of the 5 race USAC Silver crown win streak. Pictured here at the Lucas Oil Raceway before their May 25th win. Hampshire&#8217;s DePalma Racing based in Lima, Ohio, was the USAC Silver Crown winningest team owners with seven national titles dating back to 1986. For 2019 Swanson will drive for Gene Nolen racing, Whiteland, Indiana. (Richard Golardi photo )</p></div>
<p><span style="color: #ff0000"><em><strong>Speaking of National Winners!</strong></em></span></p>
<div id="attachment_3787" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison.jpg"><img class="size-large wp-image-3787" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-600x600.jpg" alt="" width="600" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-600x600.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-250x250.jpg 250w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-450x450.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-768x768.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-25x25.jpg 25w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-75x75.jpg 75w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-150x150.jpg 150w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison-300x300.jpg 300w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/WAR-Gramps-and-Wyatt-photo-comparison.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">After winning the Valvoline Fast Track To Fame contest, WAR produced a throwback scheme honoring crew chief/grandfather Bob Alexander. One can see the resemblance in the comparative photos. (WAR photo)</p></div>
<p>Ellsworth native Wyatt Alexander, after a nationwide poll, was named Valvoline&#8217;s Fast Track to Fame winner earlier this year. First place carried with it about $43,000 in cash and merchandise that gave the Wyatt Alexander Racing (WAR) team more flexibility in scheduling as well as marketing.</p>
<p>Alexander made his announcement on social media this way, &#8220;Well here it is, the moment you’ve all been waiting for. WAR is proud to announce we have WON the Valvoline Fast Track to Fame! We are all still speechless but the only thing I can say is THANK YOU to everyone who has made this possible, each and every vote means the world to all of us. The community and support behind us has truly been amazing. This is huge for our team and my career.&#8221;</p>
<p>“This program was an opportunity to show our continued support for motorsports and those who live the ‘Never Idle’ mantra that Valvoline is rooted in,” said Travis Montgomery, head of sports marketing and entertainment for Valvoline. “We were looking for someone with grit, passion and drive, and there is no doubt we found those qualities and more in Wyatt&#8221;</p>
<p>Alexander found out he was a national winner July 17 shortly after racing at the family &#8220;home track&#8221;, Spud Speedway for the Firecracker 200 July 3rd where he finished seventh. He exemplifies the &#8220;on the move&#8221; example serving as a race official this weekend at the World Karting Association (WKA) Kartweek Nationals at Daytona International Speedway.</p>
<p><em><strong><span style="color: #ff0000">I get a ride at the &#8220;Club&#8221;</span></strong></em></p>
<div id="attachment_3788" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-aerial-view.jpg"><img class="size-large wp-image-3788" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-aerial-view-600x263.jpg" alt="" width="600" height="263" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-aerial-view-600x263.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-aerial-view-450x197.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-aerial-view-768x336.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-aerial-view.jpg 1408w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Aerial view of most of the 2.5 mile road course built on the hills of Tamworth overlooking hills of the Appalachian trail. (Club Motorsports photo)</p></div>
<p>While in New Hampshire in early August for the Soulfest 2018 at Gunstock Mountain, I took a little side trip to visit the Club Motorsports new road course in Tamworth, New Hampshire. I met with track supervisor Jason Brackett from Minot, Maine.</p>
<div id="attachment_3789" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-Jason-Brackett-with-Chevy-Impala-HTF-Moto.jpg"><img class="size-large wp-image-3789" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-Jason-Brackett-with-Chevy-Impala-HTF-Moto-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-Jason-Brackett-with-Chevy-Impala-HTF-Moto-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-Jason-Brackett-with-Chevy-Impala-HTF-Moto-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Club-Motorsports-Jason-Brackett-with-Chevy-Impala-HTF-Moto-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Club Motorsports Jason Brackett with his 2015 Chevy Impala SS. I had the opportunity to make three laps with Jason driving around the 2.5 mile course at speed over 100 mph. I was in good hands. Find out more in Episode 228, September 2, 2018. (HTF Motorsports photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Fastest Non-Bonneville Corvette on the planet</strong></em></span></p>
<p>I have had the privilege of following the land speed efforts of Northwood, New Hampshire&#8217;s Jason White in his C6 Corvette. I remember him starting out with licensing runs in 2014 at 175 mph with stock running gear. Much has changed since then, however, one thing has not changed that is his enthusiasm for the sport and willingness to talk with people at the track. Looking forward to see what he has got cooking in 2019.</p>
<div id="attachment_3790" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Jason-Whites-Corvette-Loring-July-2018-Stacy-Robey-photop.jpg"><img class="size-large wp-image-3790" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Jason-Whites-Corvette-Loring-July-2018-Stacy-Robey-photop-600x285.jpg" alt="" width="600" height="285" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Jason-Whites-Corvette-Loring-July-2018-Stacy-Robey-photop-600x285.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Jason-Whites-Corvette-Loring-July-2018-Stacy-Robey-photop-450x214.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Jason-Whites-Corvette-Loring-July-2018-Stacy-Robey-photop-768x364.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Jason White record-setting C6 Corvette &#8220;under-the-hood&#8221; shot. White set the fastest time at Loring Timing Association (LTA) Harvest Event in September 267.422 mph. (Stacy Robey photo)</p></div>
<p><span style="color: #ff0000"><em><strong>Autocross rounds out the Loring racing scene</strong></em></span></p>
<p>Northern Maine plays host to the fastest motorcycles and cars on the planet at the former Loring Air Force base hosted by Loring Timing Association. The abandoned base also plays host to the Cumberland Motor Club autocross for the past nine years in early August.</p>
<p>Their track is one of the largest venues in the eastern United States. They typically draw nearly one hundred contestants for each of their two-day event. Cars range from street cars to purebred race track only cars plus racing karts.</p>
<div id="attachment_3791" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Cumberland-Motor-Club-Loring-2018-Philip-Winslow-photo.jpg"><img class="size-large wp-image-3791" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Cumberland-Motor-Club-Loring-2018-Philip-Winslow-photo-600x338.jpg" alt="" width="600" height="338" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Cumberland-Motor-Club-Loring-2018-Philip-Winslow-photo-600x338.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Cumberland-Motor-Club-Loring-2018-Philip-Winslow-photo-450x253.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Cumberland-Motor-Club-Loring-2018-Philip-Winslow-photo-768x432.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Cumberland-Motor-Club-Loring-2018-Philip-Winslow-photo.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">An &#8220;inside view&#8221;of a race track only car minus a few body panels is this Dragon SR2 built by Bill Gendron, Small Fortune Racing, Monson, Massachusetts. (Philip Winslow photo)</p></div>
<div id="attachment_3792" style="width: 610px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Baxley-Speed-Shop-Infiniti-at-Loring-2018-HTF-Moto.jpg"><img class="size-large wp-image-3792" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Baxley-Speed-Shop-Infiniti-at-Loring-2018-HTF-Moto-600x450.jpg" alt="" width="600" height="450" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Baxley-Speed-Shop-Infiniti-at-Loring-2018-HTF-Moto-600x450.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Baxley-Speed-Shop-Infiniti-at-Loring-2018-HTF-Moto-450x338.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/Baxley-Speed-Shop-Infiniti-at-Loring-2018-HTF-Moto-768x576.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Baxley Speed Shop Infiniti G35 driven by Ben Spatafora awaiting a run during day two of this year&#8217;s autocross at Loring. Spatafora set fastest time in the E Street Prepared class. (HTF Motorsports photo)</p></div>
<p><span style="color: #ff0000"><em><strong>See you in 2019? Thanks to all who were part of my 2018 adventure.</strong></em></span></p>
<div id="attachment_3793" style="width: 439px" class="wp-caption alignnone"><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/HTF-at-Mount-Philo-2018-Erika-Cole-photo.jpg"><img class="size-large wp-image-3793" src="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/HTF-at-Mount-Philo-2018-Erika-Cole-photo-429x600.jpg" alt="" width="429" height="600" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/HTF-at-Mount-Philo-2018-Erika-Cole-photo-429x600.jpg 429w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/HTF-at-Mount-Philo-2018-Erika-Cole-photo-322x450.jpg 322w, https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/HTF-at-Mount-Philo-2018-Erika-Cole-photo.jpg 686w" sizes="(max-width: 429px) 100vw, 429px" /></a><p class="wp-caption-text">Closed this year out with a little sledding action with my family at Mount Philo in Vermont (the same course used for the Hillclimb race). Note who is the most covered in snow and slowest to boot. front left to right Caleb Courtemanche and Lila Cole. Back (l to r) Christian and Jessica Courtemanche, Erika and Marc Cole and yours truly. Happy New Year folks. Hope to see you in 2019. (Erika Cole photo)</p></div>
<p>Let&#8217;s go racing in 2019,</p>
<p>Tom Hale</p>
<p>Soli Deo Gloria (Matthew 5:16)</p>

		</div>
			
			        <script type="text/javascript">
            try {
                _402_Show();
            } catch (e) {
            }
        </script>
	    
			
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="2018 in the rear view mirror."
               data-url="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-250x250.jpg&description=2018 in the rear view mirror" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


	</div><!-- .entry-content -->

	
	<footer class="entry-meta">
	    				                    
<div class="author-info">
	<div class="author-avatar">
			    <img src="http://gravatar.com/avatar/a67b779fa5e32cc5ee2d8c79985865ae?s=74&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F244%2Ffiles%2F2014%2F04%2FIMG_09581-300x300.jpg"
		 alt="Tom Hale"
		 title="Tom Hale"
		 class="gravatar avatar"
		 align="left"
		 width="74" 
		 height="74" 
		 />
	</div><!-- .author-avatar -->
	<div class="author-description">
		<h2 class="author-title">About Tom Hale</h2>
		<p class="author-bio">
			Tom wrote 14 years as  freelancer for the Bangor Daily Sports covering motorsports in Maine. Now blogging and concentrating on human interest stories about people and places in racing. He races Champ Karts and owns HTF Motorsports in remote Westmanland, Maine                    
                        		</p>
	</div><!-- .author-description -->
</div><!-- .author-info -->		    			</footer><!-- .entry-meta -->
</article><!-- #post -->
					<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<a href="https://upnorthmotorsports.bangordailynews.com/2018/12/24/home/my-quest-for-horsepower/" rel="prev"><span class="meta-nav">&larr;</span> My quest for horsepower</a>			
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	   
		    
				<div class="OUTBRAIN entry-meta" data-src="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" data-widget-id="AR_1" data-ob-template="bangordaily" ></div>
				<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>

				
<div id="comments" class="comments-area comment-respond">
    <div class="comment-list">
            
            <div class="fb-comments" data-href="http://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" data-colorscheme="light" data-width="604"></div>
            
                        <script>
                jQuery(document).ready(function( $ ) {
                     FB.Event.subscribe('comment.create', function(response) {

                        //Send an email with ajax

                        $.ajax({
                            type: "GET",
                            url: "/wp-admin/admin-ajax.php?action=bdn_facebook_comment_notifications_send",
                            data: { 
                                post_author : "thale@reagan.com", 
                                post_title : "2018 in the rear view mirror", 
                                post_link : "https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/", 
                                post_id : "3764"
                            }, 
                            dataType: "json",
                            beforeSend:  function() {
                                console.log('Sending message');
                            },
                            success: function(html){
                               console.log('Success sending email');
                               console.log(html);
                            },
                            error: function(html){
                                console.log('There was an error sending the notification email');
                                console.log(html)
                            }
                        });
                     });
                });
               
            </script>
                        
            
            
           
    </div>
</div><!-- #comments -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


	
    <div id="tertiary" class="sidebar-container" role="complementary">
	<div class="sidebar-inner">
	    <div class="widget-area">

		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-top-300x250">
		     <script type="text/javascript">
			  googletag.cmd.push(function() {
				googletag.display("bdnads-blogs-top-300x250");
			   });
		      </script>
		    </div>
		</div>

		<aside id="bdn_blog_bio-2" class="widget widget_bdn_blog_bio"><h3 class="widget-title">                <div class="widget blog-authors">
                    <h3>Tom Hale</h3>
                    <a class="author-avatar" href="">
                        <img src="http://gravatar.com/avatar/a67b779fa5e32cc5ee2d8c79985865ae?s=80&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F244%2Ffiles%2F2014%2F04%2FIMG_09581-300x300.jpg"
                             alt="Tom Hale"
                             title="Tom Hale"
                             class="gravatar avatar"
                             align="left"
                             width="80" 
                             height="80" 
                         />
                    </a>
                    <p>
                        Tom wrote 14 years as  freelancer for the Bangor Daily Sports covering motorsports in Maine. Now blogging and concentrating on human interest stories about people and places in racing. He races Champ Karts and owns HTF Motorsports in remote Westmanland, Maine                    </p>
                    
                                        
                                        
                    
                </div>
                
        </h3></aside>        <div class="bdn-blogs-widget widget category-sports">
            <!--
            Document   : Formerly bdn-blog-promotions.css
            Created on : Sep 16, 2013, 4:43:03 PM
            Author     : Pattie Reaves
            Version	   : 1.1
            Description: Styles the BDN blogs widget.
             -->
            <style>
                .bdn-blog-headshot {
                    width: 70px;
                    height: 70px;
                    -moz-border-radius: 35px;
                    -webkit-border-radius: 35px;
                    border-radius: 35px;
                }

                .bdn-blogs-widget-posts img {
                    margin: 0 10px 10px 0;
                }

                .bdn-blogs-widget-posts {
                    border: #006743 solid 1px;
                    padding: 5px;
                }

                .bdn-blogs-widget-header {
                    overflow: auto;
                    background-color: #006743;
                    color: #fff;
                }

                .bdn-blogs-widget-header img {margin-right: 10px;}
                .bdn-blogs-widget-header h3 {font-size: 50px; clear: right; margin: 10px;}
                .widget .bdn-blogs-widget-header a, .widget .bdn-blogs-widget-header a:visited {color: #fff; line-height: 30px;}

                .blogwidget {
                    margin: 10px 0;
                    padding: 10px 0;
                    overflow: auto;
                    border-bottom: 1px solid #ddd;
                }

                .blogwidget:first-of-type {
                    margin-top: 0;
                }
                .blogwidget:last-of-type {
                    margin-bottom: 0;
                }

                .bdn-blogs-widget-header .promo-links {margin-left: 5px;}

                h4.blogstory, h5.blogname {
                    margin: 0;
                }

                h5.blogname {text-transform: uppercase; font-size: 75%;}

                a.post-image {
                    text-indent: -99999px;
                    display: block;
                    width: 100%;
                    height: 180px;
                    margin-bottom: 5px;
                    background-repeat: no-repeat;
                    background-position: center center;
                    background-color: #ccc;
                }
            </style>
            <div class="bdn-blogs-widget-header">
                <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget">
                    <img src="//bangordailynews.com/wp-content/themes/bdn/images/bdnmaine_110.png" width="60"
                         align="left">
                </a>
                <h3>
                    <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget">
                        Blogs
                    </a>
                </h3>
                <div class="promo-links">
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/be-a-bdn-blogger/">Be a BDN
                        blogger</a> |
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/">Browse BDN blogs</a>
                </div>
            </div>
            <div class="bdn-blogs-widget-posts">
				<!-- Blogs widget served from memcached --><!-- blogs category: sports -->
            <div id="blogwidget_1" class="blogwidget">

                <h5 class="blogname">
                    <a href="https://offtherim.bangordailynews.com/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank title="Covering all aspects of high school, prep, college and pro basketball.">
						Off the Rim                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/44/files/2018/12/CLASSCBOYS-3_22894783-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="https://offtherim.bangordailynews.com/2018/12/31/high-school/this-four-season-formula-helps-basketball-teams-in-tourney-quests/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                            title="This four-season formula helps basketball teams in tourney quests">
						This four-season formula helps basketball teams in tourney quests                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="https://offtherim.bangordailynews.com/2018/12/31/high-school/this-four-season-formula-helps-basketball-teams-in-tourney-quests/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank>
						This four-season formula helps basketball teams in tourney quests                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_2" class="blogwidget">

                <h5 class="blogname">
                    <a href="https://upnorthmotorsports.bangordailynews.com/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank title="People and events in motorsports">
						Up North Motorsports                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/12/2018-Speedweeks-Tri-Oval-DIS-photo-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                            title="2018 in the rear view mirror">
						2018 in the rear view mirror                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank>
						2018 in the rear view mirror                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_3" class="blogwidget">

                <h5 class="blogname">
                    <a href="https://thedrive.bangordailynews.com/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank title="Your sports. Your teams. Your show.">
						The Drive                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/the-drive-square-logo-300x300.png'); background-position: center center; background-size: cover;"
                            href="https://thedrive.bangordailynews.com/2018/12/29/sports/sterling-notes-nfl-week-17/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                            title="Sterling Notes: NFL week 17">
						Sterling Notes: NFL week 17                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="https://thedrive.bangordailynews.com/2018/12/29/sports/sterling-notes-nfl-week-17/?utm_campaign=Up+North+Motorsports&utm_source=sports-widget"
                       target=_blank>
						Sterling Notes: NFL week 17                    </a>
                </h4>
            </div>

		            </div>

        </div><!-- /.bdn-blogs-widget -->

		<!-- Blogs widget took 0.002852 seconds to load. -->
		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-bottom-300x250">
			 <script type="text/javascript">
			      googletag.cmd.push(function() {
				    googletag.display("bdnads-blogs-bottom-300x250");
			       });
			  </script>
		    </div>
		</div>
	    </div><!-- .widget-area -->

	</div><!-- .sidebar-inner -->
    </div><!-- #tertiary -->
	
	

		</div><!-- #main -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div id="secondary" class="sidebar-container" role="complementary">
		<div class="widget-area">
			<aside id="blog_subscription-2" class="widget jetpack_subscription_widget"><h3 class="widget-title">Subscribe to Blog via Email</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 21 other subscribers</p>
					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="https://upnorthmotorsports.bangordailynews.com/2018/12/31/home/2018-in-the-rear-view-mirror/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside><aside id="rss_links-2" class="widget widget_rss_links"><h3 class="widget-title">Subscribe via RSS</h3><p><a target="_self" href="https://upnorthmotorsports.bangordailynews.com/feed/" title="Subscribe to Posts"><img src="https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/images/rss/orange-small.png" alt="RSS Feed" /></a>&nbsp;<a target="_self" href="https://upnorthmotorsports.bangordailynews.com/feed/" title="Subscribe to Posts">RSS - Posts</a></p>
</aside><aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="search-form" action="https://upnorthmotorsports.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form></aside><aside id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/12/'>December 2018</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/11/'>November 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/10/'>October 2018</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/09/'>September 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/08/'>August 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/07/'>July 2018</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/06/'>June 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/05/'>May 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/04/'>April 2018</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/03/'>March 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/02/'>February 2018</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2018/01/'>January 2018</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/12/'>December 2017</a>&nbsp;(3)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/11/'>November 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/10/'>October 2017</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/09/'>September 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/08/'>August 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/07/'>July 2017</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/06/'>June 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/05/'>May 2017</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/04/'>April 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/03/'>March 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/02/'>February 2017</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2017/01/'>January 2017</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/12/'>December 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/11/'>November 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/10/'>October 2016</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/09/'>September 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/08/'>August 2016</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/07/'>July 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/06/'>June 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/05/'>May 2016</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/04/'>April 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/03/'>March 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/02/'>February 2016</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2016/01/'>January 2016</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/12/'>December 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/11/'>November 2015</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/10/'>October 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/09/'>September 2015</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/08/'>August 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/07/'>July 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/06/'>June 2015</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/05/'>May 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/04/'>April 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/03/'>March 2015</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/02/'>February 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2015/01/'>January 2015</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/12/'>December 2014</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/11/'>November 2014</a>&nbsp;(3)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/10/'>October 2014</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/09/'>September 2014</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/08/'>August 2014</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/07/'>July 2014</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/06/'>June 2014</a>&nbsp;(4)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/05/'>May 2014</a>&nbsp;(5)</li>
	<li><a href='https://upnorthmotorsports.bangordailynews.com/2014/04/'>April 2014</a>&nbsp;(2)</li>
		</ul>
		</aside><aside id="meta-2" class="widget widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="https://bangordailynews.com/new-account/">Register</a></li>			<li><a href="https://upnorthmotorsports.bangordailynews.com/wp-login.php">Log in</a></li>
			<li><a href="https://upnorthmotorsports.bangordailynews.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://upnorthmotorsports.bangordailynews.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>		</div><!-- .widget-area -->
	</div><!-- #secondary -->

			<div class="site-info">
                            <a href="http://bangordailynews.com/maine-blogs/?utm_source=Up+North+Motorsports&utm_medium=footer">
                                <img src="https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg" width="32" />
                                Up North Motorsports is a member of the BDN Maine Blog network.
                            </a>
			</div><!-- .site-info -->
			
			<!--Desktop only-->
			<div id="footer">
			    <div id="box-wrap">
				<div id="box1">
				    <h1 class="headline">Bangor Daily News</h1>
				    <ul class="sitemap">
					<li><a href="http://archive.bangordailynews.com/">Archives</a></li>
					<li><a href="http://bangordailynews.com/">News</a></li>
					<li><a href="http://bangordailynews.com/business/">Business</a></li>
					<li><a href="http://bangordailynews.com/sports/">Sports</a></li>
					<li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li>
					<li><a href="http://bangordailynews.com/homestead/">Homestead</a></li>
					<li><a href="http://bangordailynews.com/link/tv-listings/">TV Listings</a></li>
					<li><a href="http://obituaries.bangordailynews.com/">Obituaries</a></li>
					<li><a href="http://bangordailynews.com/events/">Things to Do</a></li>
					<li><a href="http://bangordailynews.com/special-sections/">Custom Publications</a></li>
					<li><a href="http://marketplace.bangordailynews.com/?post_type=coupon">Coupons</a></li>
					<li><a href="http://bangordailynews.com/weather/">Weather</a></li>
					<li><a href="http://bangordailynews.com/closings/">Storm Cancellations</a></li>
				    </ul>
				</div><!-- #box1 -->
				<div id="box2">
				    <h1 class="headline">About Us</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/about/">BDN History</a></li>
					<li><a href="http://external.bangordailynews.com/bdn-anniversary/">BDN 120 Years</a></li>
					<li><a href="http://bangordailynews.com/contact">Contact Us</a></li>
					<li><a href="http://store.bangordailynews.com/">Purchase Photos</a></li>
					<li><a href="http://nie.bangordailynews.com/">Newspapers in Education</a></li>
					<li><a href="http://bangordailynews.com/terms-of-service/">Terms of Service</a></li>
					<li><a href="http://bangordailynews.com/privacy/">Privacy Policy</a></li>
				    </ul>
				    <h1 class="headline" style="margin-top: 15px;">Subscribe</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/subscribe/">Bangor Daily News Subscriptions</a></li>
					<li><a href="http://bangordailynews.com/staff/circulation/">Manage Your Subscription</a></li>
					<li><a href="http://bangordailynews.com/newsletters/">Email Updates</a></li>
					<li><a href="http://bangordailynews.com/feed/">RSS</a></li>
				    </ul>
				</div><!-- #box2 -->
				<div id="box3">
				    <h1 class="headline">Sales and Marketing</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/staff/advertising/classifieds/">Classifieds</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Print and Online Advertising</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/special-sections/">Custom Publications and The Weekly</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Advertising Staff Directory</a></li>
					<li><a href="http://creativeservices.bangordailynews.com/guide-to-sending-files/">Creative Services-Guide to Sending Files</a></li>
				    </ul>
				</div><!-- #box3 -->
				<div id="box4">
				    <h1 class="headline">On Facebook</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.facebook.com/bangordailynews" title="The Bangor Daily News on Facebook">The Bangor Daily News</a></li>
                        <li><a href="http://www.facebook.com/bdnmainemidcoast" title="BDN Midcoast on Facebook">Midcoast</a></li>
                        <li><a href="http://www.facebook.com/bdnmaineportland" title="BDN Portland on Facebook">Portland</a></li>
                        <li><a href="http://www.facebook.com/bdnmainearoostook" title="BDN Aroostook on Facebook">Aroostook</a></li>
                        <li><a href="http://www.facebook.com/bdnmainedowneast" title="BDN Midcoast on Facebook">Downeast</a></li>
                        <li><a href="http://www.facebook.com/bdnmainehancock" title="BDN Hancock on Facebook">Hancock</a></li>
                        <li><a href="http://www.facebook.com/pages/BDN-Katahdin-and-Lincoln-Lakes-Region-News/139993822727247" title="BDN Katahdin and Lincoln Lakes Region on Facebook">Katahdin and Lincoln Lakes Region</a></li>
                        <hr />
                        <li><a href="http://www.facebook.com/BDNFoodForThought" title="BDN Food on Facebook">Food</a></li>
                        <li><a href="https://www.facebook.com/bdnmaineoutdoors" title="BDN Outdoors on Facebook">Outdoors</a></li>
                        <li><a href="https://www.facebook.com/BDNMaineFamilies" title="BDN Maine Families on Facebook">Maine Families</a></li>
                        <li><a href="https://www.facebook.com/BDNBlogs" title="BDN Blogs on Facebook">BDN Blogs</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/pages/BDN-Editorial-Opinion/107406425993156" title="BDN Editorial and Opinion on Facebook">Editorial and Opinion</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/bdnmainesports" title="BDN Maine Sports on Facebook">Maine Sports</a></li>
                        <li><a href="https://www.facebook.com/bdnhssports" title="BDN High School Sports on Facebook">High School Sports</a></li>
                    </ul>
                    <h1 class="headline">On Twitter</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.twitter.com/bangordailynews" title="The Bangor Daily News on Twitter">@bangordailynews</a></li>
                        <li><a href="http://www.twitter.com/bdnpolitics" title="The Bangor Daily News on Twitter">@bdnpolitics</a></li>
                        <li><a href="http://www.twitter.com/bdnmaineblogs" title="The Bangor Daily News Blogs on Twitter">@bdnmaineblogs</a></li>
                        <li><a href="http://www.twitter.com/bdnmainefocus" title="The Bangor Daily News Maine Focus on Twitter">@bdnmainefocus</a></li>
                    </ul>
				</div><!-- #box4 -->
			    </div><!--#box-wrap -->
			</div>
			
		</footer><!-- #colophon -->
	</div><!-- #page -->

		<div style="display:none">
	</div>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201901'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/upnorthmotorsports.bangordailynews.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/functions.js?ver=2013-07-18'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/themes/bdnblog2013/js/out-of-page-ad.js?ver=2018-07-18'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-content/mu-plugins/js/submitevent.js?ver=2'></script>
<script type='text/javascript' src='https://upnorthmotorsports.bangordailynews.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201901.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'67503481',post:'3764',tz:'-5',srv:'upnorthmotorsports.bangordailynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '67503481', '3764' ]);
</script>
</body>
</html>
